cAreaObjGetLoadUniform Method |
Retrieves the uniform load assignments to area objects.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetLoadUniform(
string Name,
ref int NumberItems,
ref string[] AreaName,
ref string[] LoadPat,
ref string[] CSys,
ref int[] Dir,
ref double[] Value,
eItemType ItemType = eItemType.Objects
)
Function GetLoadUniform (
Name As String,
ByRef NumberItems As Integer,
ByRef AreaName As String(),
ByRef LoadPat As String(),
ByRef CSys As String(),
ByRef Dir As Integer(),
ByRef Value As Double(),
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int GetLoadUniform(
String^ Name,
int% NumberItems,
array<String^>^% AreaName,
array<String^>^% LoadPat,
array<String^>^% CSys,
array<int>^% Dir,
array<double>^% Value,
eItemType ItemType = eItemType::Objects
)
abstract GetLoadUniform :
Name : string *
NumberItems : int byref *
AreaName : string[] byref *
LoadPat : string[] byref *
CSys : string[] byref *
Dir : int[] byref *
Value : float[] byref *
?ItemType : eItemType
(* Defaults:
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing area object or group, depending on the value
of the ItemType item.
- NumberItems
- Type: SystemInt32
The total number of uniform loads retrieved for the specified area objects.
- AreaName
- Type: SystemString
This is an array that includes the name of the area object associated
with each uniform load.
- LoadPat
- Type: SystemString
This is an array that includes the name of the load pattern associated
with each uniform load.
- CSys
- Type: SystemString
This is an array that includes the name of the coordinate system
associated with each uniform load.
- Dir
- Type: SystemInt32
- Value
- Type: SystemDouble
The uniform load value. [F/L^2]
- ItemType (Optional)
- Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignments are retrieved
for the area object specified by the Name item.
If this item is Group, the assignments are retrieved
for all area objects in the group specified by the Name item.
If this item is SelectedObjects, assignments are retrieved
for is made to all selected area objects, and the Name item is ignored.
Return Value
Type:
Int32
Returns zero if the load assignments are successfully retrieved;
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim NumberItems As Long
Dim AreaName() As String
Dim LoadPat() As String
Dim CSys() As String
Dim Dir() As Long
Dim Value() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.AreaObj.SetLoadUniform("ALL", "DEAD", -0.01, 2, False, "Local", eItemType.Group)
ret = SapModel.AreaObj.GetLoadUniform("3", NumberItems, AreaName, LoadPat, CSys, Dir, Value)
ret = SapModel.View.RefreshView(0, False)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also