Creates a new steel deck model from template.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint NewSteelDeck(
int NumberStorys,
double TypicalStoryHeight,
double BottomStoryHeight,
int NumberLinesX,
int NumberLinesY,
double SpacingX,
double SpacingY
)
Function NewSteelDeck (
NumberStorys As Integer,
TypicalStoryHeight As Double,
BottomStoryHeight As Double,
NumberLinesX As Integer,
NumberLinesY As Integer,
SpacingX As Double,
SpacingY As Double
) As Integer
int NewSteelDeck(
int NumberStorys,
double TypicalStoryHeight,
double BottomStoryHeight,
int NumberLinesX,
int NumberLinesY,
double SpacingX,
double SpacingY
)
abstract NewSteelDeck :
NumberStorys : int *
TypicalStoryHeight : float *
BottomStoryHeight : float *
NumberLinesX : int *
NumberLinesY : int *
SpacingX : float *
SpacingY : float -> int
Parameters
- NumberStorys
- Type: SystemInt32
The number of stories in the model - TypicalStoryHeight
- Type: SystemDouble
The story height that will be used for all stories in the model,
except the bottom story. [L] - BottomStoryHeight
- Type: SystemDouble
The story height that will be used for the bottom story. [L] - NumberLinesX
- Type: SystemInt32
The number of grid lines in the X direction. - NumberLinesY
- Type: SystemInt32
The number of grid lines in the Y direction. - SpacingX
- Type: SystemDouble
The uniform spacing for grid lines in the X direction. [L] - SpacingY
- Type: SystemDouble
The uniform spacing for grid lines in the Y direction. [L]
Return Value
Type:
Int32Returns zero if the new steel deck model is successfully created;
otherwise it returns a nonzero value.
RemarksDo not use this function to add to an existing model.
This function should be used only for creating a new model and typically would be preceded
by a call to
InitializeNewModel(eUnits).
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also