cPropLinkGetNameList Method

Retrieves the names of all defined link properties of the specified type.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetNameList(
	ref int NumberNames,
	ref string[] MyName,
	eLinkPropType PropType = 
)

Parameters

NumberNames
Type: SystemInt32
The number of link property names retrieved by the program.
MyName
Type: SystemString
This is a one-dimensional array of link property names. The MyName array is created as a dynamic, zero-based, array by the API user: Dim MyName() as String

The array is dimensioned to (NumberNames - 1) inside the program, filled with the names, and returned to the API user.

PropType (Optional)
Type: ETABS2016eLinkPropType
This optional value is one of the items in the eLinkPropType enumeration.

If no value is input for PropType, names are returned for all link properties in the model regardless of type.

Return Value

Type: Int32
Returns zero if the names are successfully retrieved; otherwise it returns nonzero.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim DOF() As Boolean
       Dim Fixed() As Boolean
       Dim Ke() As Double
       Dim Ce() As Double
       Dim NumberNames As Integer
       Dim MyName() As String

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'add link property
       ReDim DOF(5)
       ReDim Fixed(5)
       ReDim Ke(5)
       ReDim Ce(5)
       DOF(0) = True
       Ke(0) = 12
       ret = SapModel.PropLink.SetLinear("L1", DOF, Fixed, Ke, Ce, 0, 0)

   'get link property names
       ret = SapModel.PropLink.GetNameList(NumberNames, MyName)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also