cPropLinkGetMultiLinearPoints Method |
Retrieves the force-deformation data for a specified degree of freedom in
multilinear elastic and multilinear plastic link properties.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetMultiLinearPoints(
string Name,
int DOF,
ref int NumberPoints,
ref double[] F,
ref double[] D,
ref int MyType,
ref double A1,
ref double A2,
ref double B1,
ref double B2,
ref double Eta
)
Function GetMultiLinearPoints (
Name As String,
DOF As Integer,
ByRef NumberPoints As Integer,
ByRef F As Double(),
ByRef D As Double(),
ByRef MyType As Integer,
ByRef A1 As Double,
ByRef A2 As Double,
ByRef B1 As Double,
ByRef B2 As Double,
ByRef Eta As Double
) As Integer
int GetMultiLinearPoints(
String^ Name,
int DOF,
int% NumberPoints,
array<double>^% F,
array<double>^% D,
int% MyType,
double% A1,
double% A2,
double% B1,
double% B2,
double% Eta
)
abstract GetMultiLinearPoints :
Name : string *
DOF : int *
NumberPoints : int byref *
F : float[] byref *
D : float[] byref *
MyType : int byref *
A1 : float byref *
A2 : float byref *
B1 : float byref *
B2 : float byref *
Eta : float byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing multilinear elastic or multilinear plastic link property. - DOF
- Type: SystemInt32
- NumberPoints
- Type: SystemInt32
The number of foce-defomation points for the specified degree of freedom. - F
- Type: SystemDouble
This is an array, dimensioned to NumberPoints - 1,
that includes the force at each point. When DOF is U1, U2 or U3, this is a force.
When DOF is R1, R2 or R3. this is a moment.
[F] if DOF is less than or equal to 3,
and [FL] if DOF is greater than 3. - D
- Type: SystemDouble
- MyType
- Type: SystemInt32
This item applies only to multilinear plastic link properties.
It is 1, 2 or 3, indicating the hysteresis type.
MyTpe | Hysteresis Type |
---|
1 | Kinematic |
2 | Takeda |
3 | Pivot |
- A1
- Type: SystemDouble
- A2
- Type: SystemDouble
- B1
- Type: SystemDouble
- B2
- Type: SystemDouble
- Eta
- Type: SystemDouble
Return Value
Type:
Int32Returns zero if the data is successfully assigned;
otherwise it returns a nonzero value.
RemarksTo successfully retrieve this data from the indicated link property,
the following conditions must be met:
- The link property must be multilinear elastic or multilinear plastic.
- The specified DOF must be active.
- The specified DOF must not be fixed.
- The specified DOF must be nonlinear.
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim MyDOF() As Boolean
Dim MyFixed() As Boolean
Dim MyNonLinear() as Boolean
Dim MyKe() As Double
Dim MyCe() As Double
Dim MyF() As Double
Dim MyD() As Double
Dim NumberPoints As Integer
Dim F() As Double
Dim D() As Double
Dim MyType As Integer
Dim a1 As Double
Dim a2 As Double
Dim b1 As Double
Dim b2 As Double
Dim eta As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ReDim MyDOF(5)
ReDim MyFixed(5)
ReDim MyNonLinear(5)
ReDim MyKe(5)
ReDim MyCe(5)
MyDOF(0) = True
MyKe(0) = 12
MyCe(0) = 0.01
MyDOF(1) = True
MyNonLinear(1) = True
MyKe(1) = 12
MyCe(1) = 0.01
MyDOF(2) = True
MyFixed(2) = True
ret = SapModel.PropLink.SetMultiLinearPlastic("MLP1", MyDOF, MyFixed, MyNonLinear, MyKe, MyCe, 2, 0)
ReDim MyF(4)
ReDim MyD(4)
MyF(0) = -12
MyF(1) = -10
MyF(2) = 0
MyF(3) = 8
MyF(4) = 9
MyD(0) = -8
MyD(1) = -0.6
MyD(2) = 0
MyD(3) = 0.2
MyD(4) = 6
ret = SapModel.PropLink.SetMultiLinearPoints("MLP1", 2, 5, MyF, MyD, 3, 9, 12, 0.75, 0.8, .1)
ret = SapModel.PropLink.GetMultiLinearPoints("MLP1", 2, NumberPoints, F, D, MyType, a1, a2, b1, b2, eta)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also