cPropLinkSetMultiLinearPoints Method |
Sets the force-deformation data for a specified degree of freedom in multilinear elastic
and multilinear plastic link properties.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetMultiLinearPoints(
string Name,
int DOF,
int NumberPoints,
ref double[] F,
ref double[] D,
int MyType = 1,
double A1 = 0,
double A2 = 0,
double B1 = 0,
double B2 = 0,
double Eta = 0
)
Function SetMultiLinearPoints (
Name As String,
DOF As Integer,
NumberPoints As Integer,
ByRef F As Double(),
ByRef D As Double(),
Optional MyType As Integer = 1,
Optional A1 As Double = 0,
Optional A2 As Double = 0,
Optional B1 As Double = 0,
Optional B2 As Double = 0,
Optional Eta As Double = 0
) As Integer
int SetMultiLinearPoints(
String^ Name,
int DOF,
int NumberPoints,
array<double>^% F,
array<double>^% D,
int MyType = 1,
double A1 = 0,
double A2 = 0,
double B1 = 0,
double B2 = 0,
double Eta = 0
)
abstract SetMultiLinearPoints :
Name : string *
DOF : int *
NumberPoints : int *
F : float[] byref *
D : float[] byref *
?MyType : int *
?A1 : float *
?A2 : float *
?B1 : float *
?B2 : float *
?Eta : float
(* Defaults:
let _MyType = defaultArg MyType 1
let _A1 = defaultArg A1 0
let _A2 = defaultArg A2 0
let _B1 = defaultArg B1 0
let _B2 = defaultArg B2 0
let _Eta = defaultArg Eta 0
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing multilinear elastic or multilinear plastic link property. - DOF
- Type: SystemInt32
- NumberPoints
- Type: SystemInt32
The number of foce-defomation points for the specified degree of freedom. - F
- Type: SystemDouble
This is an array, dimensioned to NumberPoints - 1,
that includes the force at each point. When DOF is U1, U2 or U3, this is a force.
When DOF is R1, R2 or R3. this is a moment.
[F] if DOF is less than or equal to 3,
and [FL] if DOF is greater than 3. - D
- Type: SystemDouble
- MyType (Optional)
- Type: SystemInt32
This item applies only to multilinear plastic link properties.
It is 1, 2 or 3, indicating the hysteresis type.
MyTpe | Hysteresis Type |
---|
1 | Kinematic |
2 | Takeda |
3 | Pivot |
- A1 (Optional)
- Type: SystemDouble
- A2 (Optional)
- Type: SystemDouble
- B1 (Optional)
- Type: SystemDouble
- B2 (Optional)
- Type: SystemDouble
- Eta (Optional)
- Type: SystemDouble
Return Value
Type:
Int32Returns zero if the data is successfully assigned;
otherwise it returns a nonzero value.
RemarksTo successfully apply this data to the indicated link property,
the following conditions must be met:
- The link property must be multilinear elastic or multilinear plastic.
- The specified DOF must be active.
- The specified DOF must not be fixed.
- The specified DOF must be nonlinear.
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim MyDOF() As Boolean
Dim MyFixed() As Boolean
Dim MyNonLinear() as Boolean
Dim MyKe() As Double
Dim MyCe() As Double
Dim MyF() As Double
Dim MyD() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ReDim MyDOF(5)
ReDim MyFixed(5)
ReDim MyNonLinear(5)
ReDim MyKe(5)
ReDim MyCe(5)
MyDOF(0) = True
MyKe(0) = 12
MyCe(0) = 0.01
MyDOF(1) = True
MyNonLinear(1) = True
MyKe(1) = 12
MyCe(1) = 0.01
MyDOF(2) = True
MyFixed(2) = True
ret = SapModel.PropLink.SetMultiLinearPlastic("MLP1", MyDOF, MyFixed, MyNonLinear, MyKe, MyCe, 2, 0)
ReDim MyF(4)
ReDim MyD(4)
MyF(0) = -12
MyF(1) = -10
MyF(2) = 0
MyF(3) = 8
MyF(4) = 9
MyD(0) = -8
MyD(1) = -0.6
MyD(2) = 0
MyD(3) = 0.2
MyD(4) = 6
ret = SapModel.PropLink.SetMultiLinearPoints("MLP1", 2, 5, MyF, MyD, 3, 9, 12, 0.75, 0.8, .1)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also