cLinkObjGetElm Method

Retrieves the name of the link element (analysis model link) associated with a specified link object in the object-based model.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetElm(
	string Name,
	ref string Elm
)

Parameters

Name
Type: SystemString
The name of an existing link object.
Elm
Type: SystemString

Return Value

Type: Int32
Returns zero if the link element name is successfully retrieved; otherwise it returns nonzero. An error occurs if the analysis model does not exist.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim Name As String
       Dim Elm As String

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'add link object by points
       ret = SapModel.LinkObj.AddByPoint("1", "5", Name)

   'create the analysis model
       ret = SapModel.Analyze.CreateAnalysisModel

   'get link element name
       ret = SapModel.LinkObj.GetElm(Name, Elm)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also