cPropMaterialGetMassSource_1 Method |
Retrieves the mass source for the model.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetMassSource_1(
ref bool IncludeElements,
ref bool IncludeAddedMass,
ref bool IncludeLoads,
ref int NumberLoads,
ref string[] LoadPat,
ref double[] sf
)
Function GetMassSource_1 (
ByRef IncludeElements As Boolean,
ByRef IncludeAddedMass As Boolean,
ByRef IncludeLoads As Boolean,
ByRef NumberLoads As Integer,
ByRef LoadPat As String(),
ByRef sf As Double()
) As Integer
int GetMassSource_1(
bool% IncludeElements,
bool% IncludeAddedMass,
bool% IncludeLoads,
int% NumberLoads,
array<String^>^% LoadPat,
array<double>^% sf
)
abstract GetMassSource_1 :
IncludeElements : bool byref *
IncludeAddedMass : bool byref *
IncludeLoads : bool byref *
NumberLoads : int byref *
LoadPat : string[] byref *
sf : float[] byref -> int
Parameters
- IncludeElements
- Type: SystemBoolean
Include element self mass
- IncludeAddedMass
- Type: SystemBoolean
Include additional masses
- IncludeLoads
- Type: SystemBoolean
Include specified loads
- NumberLoads
- Type: SystemInt32
The number of load patterns from which mass is obtained.
This item applies only when IncludeLoads is True.
- LoadPat
- Type: SystemString
This is an array of the names of the load patterns from which mass is obtained.
This item applies only when IncludeLoads is True.
- sf
- Type: SystemDouble
This is an array of load patterns multipliers used to calculate the mass.
This item applies only when IncludeLoads is True.
Return Value
Type:
Int32Returns zero if the mass source is successfully retrieved;
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim MyLoadPat() As String
Dim MySF() As Double
Dim MyOption As Integer
Dim NumberLoads As Integer
Dim LoadPat() As String
Dim sf() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ReDim MyLoadPat(1)
ReDim MySF(1)
MyLoadPat(0) = "DEAD"
MyLoadPat(1) = "LIVE"
MySF(0) = 1
MySF(1) = 0.2
ret = SapModel.PropMaterial.SetMassSource(3, 2, MyLoadPat, MySF)
ret = SapModel.PropMaterial.GetMassSource(MyOption, NumberLoads, LoadPat, sf)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also