cPropLinkGetPDelta Method |
retrieves P-delta parameters for a link property.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetPDelta(
string Name,
ref double[] Value
)
Function GetPDelta (
Name As String,
ByRef Value As Double()
) As Integer
int GetPDelta(
String^ Name,
array<double>^% Value
)
abstract GetPDelta :
Name : string *
Value : float[] byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing link property. - Value
- Type: SystemDouble
This is an array of P-delta parameters
Value | PDelta Parameter |
---|
Value(0) | M2 P-delta to I-end of link as moment, M2I |
Value(1) | M2 P-delta to J-end of link as moment, M2J |
Value(2) | M3 P-delta to I-end of link as moment, M3I |
Value(3) | M3 P-delta to J-end of link as moment, M3J |
Return Value
Type:
Int32Returns zero if the values are successfully retrieved;
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim DOF() As Boolean
Dim Fixed() As Boolean
Dim Ke() As Double
Dim Ce() As Double
Dim MyValue() As Double
Dim Value() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ReDim DOF(5)
ReDim Fixed(5)
ReDim Ke(5)
ReDim Ce(5)
DOF(0) = True
Ke(0) = 12
ret = SapModel.PropLink.SetLinear("L1", DOF, Fixed, Ke, Ce, 0, 0)
ReDim MyValue(3)
MyValue(0) = 0.6
MyValue(1) = 0.4
MyValue(2) = 0.3
MyValue(3) = 0.2
ret = SapModel.PropLink.SetPDelta("L1", MyValue)
ret = SapModel.PropLink.GetPDelta("L1", Value)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also