cLineElmGetLoadDistributed Method |
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetLoadDistributed(
string Name,
ref int NumberItems,
ref string[] LineName,
ref string[] LoadPat,
ref int[] MyType,
ref string[] CSys,
ref int[] Dir,
ref double[] RD1,
ref double[] RD2,
ref double[] Dist1,
ref double[] Dist2,
ref double[] Val1,
ref double[] Val2,
eItemTypeElm ItemTypeElm = eItemTypeElm.Element
)
Function GetLoadDistributed (
Name As String,
ByRef NumberItems As Integer,
ByRef LineName As String(),
ByRef LoadPat As String(),
ByRef MyType As Integer(),
ByRef CSys As String(),
ByRef Dir As Integer(),
ByRef RD1 As Double(),
ByRef RD2 As Double(),
ByRef Dist1 As Double(),
ByRef Dist2 As Double(),
ByRef Val1 As Double(),
ByRef Val2 As Double(),
Optional ItemTypeElm As eItemTypeElm = eItemTypeElm.Element
) As Integer
int GetLoadDistributed(
String^ Name,
int% NumberItems,
array<String^>^% LineName,
array<String^>^% LoadPat,
array<int>^% MyType,
array<String^>^% CSys,
array<int>^% Dir,
array<double>^% RD1,
array<double>^% RD2,
array<double>^% Dist1,
array<double>^% Dist2,
array<double>^% Val1,
array<double>^% Val2,
eItemTypeElm ItemTypeElm = eItemTypeElm::Element
)
abstract GetLoadDistributed :
Name : string *
NumberItems : int byref *
LineName : string[] byref *
LoadPat : string[] byref *
MyType : int[] byref *
CSys : string[] byref *
Dir : int[] byref *
RD1 : float[] byref *
RD2 : float[] byref *
Dist1 : float[] byref *
Dist2 : float[] byref *
Val1 : float[] byref *
Val2 : float[] byref *
?ItemTypeElm : eItemTypeElm
(* Defaults:
let _ItemTypeElm = defaultArg ItemTypeElm eItemTypeElm.Element
*)
-> int
Parameters
- Name
- Type: SystemString
- NumberItems
- Type: SystemInt32
- LineName
- Type: SystemString
- LoadPat
- Type: SystemString
- MyType
- Type: SystemInt32
- CSys
- Type: SystemString
- Dir
- Type: SystemInt32
- RD1
- Type: SystemDouble
- RD2
- Type: SystemDouble
- Dist1
- Type: SystemDouble
- Dist2
- Type: SystemDouble
- Val1
- Type: SystemDouble
- Val2
- Type: SystemDouble
- ItemTypeElm (Optional)
- Type: ETABS2016eItemTypeElm
Return Value
Type:
Int32
See Also