cAreaObjGetLoadWindPressure Method |
Retrieves the wind pressure load assignments to area objects.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetLoadWindPressure(
string Name,
ref int NumberItems,
ref string[] AreaName,
ref string[] LoadPat,
ref int[] MyType,
ref double[] Cp,
eItemType ItemType = eItemType.Objects
)
Function GetLoadWindPressure (
Name As String,
ByRef NumberItems As Integer,
ByRef AreaName As String(),
ByRef LoadPat As String(),
ByRef MyType As Integer(),
ByRef Cp As Double(),
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int GetLoadWindPressure(
String^ Name,
int% NumberItems,
array<String^>^% AreaName,
array<String^>^% LoadPat,
array<int>^% MyType,
array<double>^% Cp,
eItemType ItemType = eItemType::Objects
)
abstract GetLoadWindPressure :
Name : string *
NumberItems : int byref *
AreaName : string[] byref *
LoadPat : string[] byref *
MyType : int[] byref *
Cp : float[] byref *
?ItemType : eItemType
(* Defaults:
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing area object or group, depending on the value
of the ItemType item.
- NumberItems
- Type: SystemInt32
The total number of wind pressure loads retrieved for the specified
area objects.
- AreaName
- Type: SystemString
This is an array that includes the name of the area object
associated with each wind pressure load.
- LoadPat
- Type: SystemString
This is an array that includes the name of the load pattern associated
with each wind pressure load.
- MyType
- Type: SystemInt32
This is an array that includes either 1 or 2, indicating the wind pressure type.
- Windward, pressure varies over height
- Other, pressure is constant over height
- Cp
- Type: SystemDouble
This is an array that includes the wind pressure coefficient value.
- ItemType (Optional)
- Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignments are retrieved
for the area object specified by the Name item.
If this item is Group, the assignments are retrieved
for all area objects in the group specified by the Name item.
If this item is SelectedObjects, assignments are retrieved
for is made to all selected area objects, and the Name item is ignored.
Return Value
Type:
Int32
Returns zero if the load assignments are successfully retrieved;
it returns a nonzero value.
Remarks
See Also