cPropLinkGetSpringData Method

retrieves length and area values for a link property that are used if the link property is specified in line and area spring assignments.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetSpringData(
	string Name,
	ref double DefinedForThisLength,
	ref double DefinedForThisArea
)

Parameters

Name
Type: SystemString
The name of an existing link property.
DefinedForThisLength
Type: SystemDouble
The link property is defined for this length in a line (frame) spring. [L]
DefinedForThisArea
Type: SystemDouble
The link property is defined for this area in an area spring. [L2]

Return Value

Type: Int32
Returns zero if the values are successfully retieved; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim DOF() As Boolean
       Dim Fixed() As Boolean
       Dim Ke() As Double
       Dim Ce() As Double
       Dim DefinedForThisLength As Double
       Dim DefinedForThisArea As Double

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'add link property
       ReDim DOF(5)
       ReDim Fixed(5)
       ReDim Ke(5)
       ReDim Ce(5)
       DOF(0) = True
       Ke(0) = 12
       ret = SapModel.PropLink.SetLinear("L1", DOF, Fixed, Ke, Ce, 0, 0)

   'set link property spring data
       ret = SapModel.PropLink.SetSpringData("L1", 12, 2)

   'get link property spring data
       ret = SapModel.PropLink.GetSpringData("L1", DefinedForThisLength, DefinedForThisArea)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also