cLinkObjSetSelected Method

Sets the selected status for link objects.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetSelected(
	string Name,
	bool Selected,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: SystemString
The name of an existing link object or group, depending on the value of the ItemType item.
Selected
Type: SystemBoolean
This item is True if the specified link object is selected; otherwise it is False.
ItemType (Optional)
Type: ETABS2016eItemType
This is one of the items in the eItemType enumeration.

If this item is Objects, the selected status is set for the link object specified by the Name item.

If this item is Group, the selected status is set for all link objects in the group specified by the Name item.

If this item is SelectedObjects, the selected status is set for all selected link objects, and the Name item is ignored.

Return Value

Type: Int32
Returns zero if the selected status is successfully set; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim Name As String

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'add link object by points
       ret = SapModel.LinkObj.AddByPoint("1", "5", Name)

   'set link object selected
       ret = SapModel.LinkObj.SetSelected("ALL", True, eItemType.Group)

   'update view
       ret = SapModel.View.RefreshView

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also