cPropLinkGetDamperFrictionSpring Method |
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetDamperFrictionSpring(
string Name,
ref bool[] dof,
ref bool[] Fixed,
ref bool[] Nonlinear,
ref double[] ke,
ref double[] ce,
ref double[] k,
ref double[] K1,
ref double[] K2,
ref double[] u0,
ref double[] us,
ref int[] direction,
ref double dj2,
ref double dj3,
ref string notes,
ref string GUID
)
Function GetDamperFrictionSpring (
Name As String,
ByRef dof As Boolean(),
ByRef Fixed As Boolean(),
ByRef Nonlinear As Boolean(),
ByRef ke As Double(),
ByRef ce As Double(),
ByRef k As Double(),
ByRef K1 As Double(),
ByRef K2 As Double(),
ByRef u0 As Double(),
ByRef us As Double(),
ByRef direction As Integer(),
ByRef dj2 As Double,
ByRef dj3 As Double,
ByRef notes As String,
ByRef GUID As String
) As Integer
int GetDamperFrictionSpring(
String^ Name,
array<bool>^% dof,
array<bool>^% Fixed,
array<bool>^% Nonlinear,
array<double>^% ke,
array<double>^% ce,
array<double>^% k,
array<double>^% K1,
array<double>^% K2,
array<double>^% u0,
array<double>^% us,
array<int>^% direction,
double% dj2,
double% dj3,
String^% notes,
String^% GUID
)
abstract GetDamperFrictionSpring :
Name : string *
dof : bool[] byref *
Fixed : bool[] byref *
Nonlinear : bool[] byref *
ke : float[] byref *
ce : float[] byref *
k : float[] byref *
K1 : float[] byref *
K2 : float[] byref *
u0 : float[] byref *
us : float[] byref *
direction : int[] byref *
dj2 : float byref *
dj3 : float byref *
notes : string byref *
GUID : string byref -> int
Parameters
- Name
- Type: SystemString
- dof
- Type: SystemBoolean
- Fixed
- Type: SystemBoolean
- Nonlinear
- Type: SystemBoolean
- ke
- Type: SystemDouble
- ce
- Type: SystemDouble
- k
- Type: SystemDouble
- K1
- Type: SystemDouble
- K2
- Type: SystemDouble
- u0
- Type: SystemDouble
- us
- Type: SystemDouble
- direction
- Type: SystemInt32
- dj2
- Type: SystemDouble
- dj3
- Type: SystemDouble
- notes
- Type: SystemString
- GUID
- Type: SystemString
Return Value
Type:
Int32
See Also