Retrieves the group data. Primarily for ETABS
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetGroup_1(
string Name,
ref int color,
ref bool SpecifiedForSelection,
ref bool SpecifiedForSectionCutDefinition,
ref bool SpecifiedForSteelDesign,
ref bool SpecifiedForConcreteDesign,
ref bool SpecifiedForAluminumDesign,
ref bool SpecifiedForStaticNLActiveStage,
ref bool SpecifiedForAutoSeismicOutput,
ref bool SpecifiedForAutoWindOutput,
ref bool SpecifiedForMassAndWeight,
ref bool SpecifiedForSteelJoistDesign,
ref bool SpecifiedForWallDesign,
ref bool SpecifiedForBasePlateDesign,
ref bool SpecifiedForConnectionDesign
)
Function GetGroup_1 (
Name As String,
ByRef color As Integer,
ByRef SpecifiedForSelection As Boolean,
ByRef SpecifiedForSectionCutDefinition As Boolean,
ByRef SpecifiedForSteelDesign As Boolean,
ByRef SpecifiedForConcreteDesign As Boolean,
ByRef SpecifiedForAluminumDesign As Boolean,
ByRef SpecifiedForStaticNLActiveStage As Boolean,
ByRef SpecifiedForAutoSeismicOutput As Boolean,
ByRef SpecifiedForAutoWindOutput As Boolean,
ByRef SpecifiedForMassAndWeight As Boolean,
ByRef SpecifiedForSteelJoistDesign As Boolean,
ByRef SpecifiedForWallDesign As Boolean,
ByRef SpecifiedForBasePlateDesign As Boolean,
ByRef SpecifiedForConnectionDesign As Boolean
) As Integer
int GetGroup_1(
String^ Name,
int% color,
bool% SpecifiedForSelection,
bool% SpecifiedForSectionCutDefinition,
bool% SpecifiedForSteelDesign,
bool% SpecifiedForConcreteDesign,
bool% SpecifiedForAluminumDesign,
bool% SpecifiedForStaticNLActiveStage,
bool% SpecifiedForAutoSeismicOutput,
bool% SpecifiedForAutoWindOutput,
bool% SpecifiedForMassAndWeight,
bool% SpecifiedForSteelJoistDesign,
bool% SpecifiedForWallDesign,
bool% SpecifiedForBasePlateDesign,
bool% SpecifiedForConnectionDesign
)
abstract GetGroup_1 :
Name : string *
color : int byref *
SpecifiedForSelection : bool byref *
SpecifiedForSectionCutDefinition : bool byref *
SpecifiedForSteelDesign : bool byref *
SpecifiedForConcreteDesign : bool byref *
SpecifiedForAluminumDesign : bool byref *
SpecifiedForStaticNLActiveStage : bool byref *
SpecifiedForAutoSeismicOutput : bool byref *
SpecifiedForAutoWindOutput : bool byref *
SpecifiedForMassAndWeight : bool byref *
SpecifiedForSteelJoistDesign : bool byref *
SpecifiedForWallDesign : bool byref *
SpecifiedForBasePlateDesign : bool byref *
SpecifiedForConnectionDesign : bool byref -> int
Parameters
- Name
- Type: SystemString
This is the name of an existing group. - color
- Type: SystemInt32
The display color for the group specified as a Integer. - SpecifiedForSelection
- Type: SystemBoolean
This item is True if the group is specified to be
used for selection; otherwise it is False. - SpecifiedForSectionCutDefinition
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining section cuts; otherwise it is False. - SpecifiedForSteelDesign
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining steel frame design groups; otherwise it is False. - SpecifiedForConcreteDesign
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining concrete frame design groups; otherwise it is False. - SpecifiedForAluminumDesign
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining aluminum frame design groups; otherwise it is False. - SpecifiedForStaticNLActiveStage
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining stages for nonlinear static analysis; otherwise it is False. - SpecifiedForAutoSeismicOutput
- Type: SystemBoolean
This item is True if the group is specified to be
used for reporting auto seismic loads; otherwise it is False. - SpecifiedForAutoWindOutput
- Type: SystemBoolean
This item is True if the group is specified to be
used for reporting auto wind loads; otherwise it is False. - SpecifiedForMassAndWeight
- Type: SystemBoolean
This item is True if the group is specified to be
used for reporting group masses and weight; otherwise it is False. - SpecifiedForSteelJoistDesign
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining steel joist design groups; otherwise it is False. - SpecifiedForWallDesign
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining wall design groups; otherwise it is False. - SpecifiedForBasePlateDesign
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining base plate design groups; otherwise it is False. - SpecifiedForConnectionDesign
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining connection design groups; otherwise it is False.
Return Value
Type:
Int32Returns zero if the group data is successfully set;
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Color as Integer
Dim SpecifiedForSelection as Boolean
Dim SpecifiedForSectionCutDefinition as Boolean
Dim SpecifiedForSteelDesign as Boolean
Dim SpecifiedForConcreteDesign as Boolean
Dim SpecifiedForAluminumDesign as Boolean
Dim SpecifiedForStaticNLActiveStage as Boolean
Dim SpecifiedForAutoSeismicOutput as Boolean
Dim SpecifiedForAutoWindOutput as Boolean
Dim SpecifiedForMassAndWeight as Boolean
Dim SpecifiedForSteelJoistDesign as Boolean
Dim SpecifiedForWallDesign as Boolean
Dim SpecifiedForBasePlateDesign as Boolean
Dim SpecifiedForConnectionDesign as Boolean
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.GroupDef.SetGroup_1("Group1", -1, True)
ret = SapModel.GroupDef.GetGroup_1("Group1", Color, SpecifiedForSelection, SpecifiedForSectionCutDefinition, SpecifiedForSteelDesign, SpecifiedForConcreteDesign, SpecifiedForAluminumDesign, SpecifiedForStaticNLActiveStage, SpecifiedForAutoSeismicOutput, SpecifiedForAutoWindOutput, SpecifiedForMassAndWeight, SpecifiedForSteelJoistDesign, SpecifiedForWallDesign, SpecifiedForBasePlateDesign, SpecifiedForConnectionDesign)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also