cLinkObjAddByCoord Method |
Adds a new link object whose end points are at the specified coordinates.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint AddByCoord(
double XI,
double YI,
double ZI,
double XJ,
double YJ,
double ZJ,
ref string Name,
bool IsSingleJoint = false,
string PropName = "Default",
string UserName = "",
string CSys = "Global"
)
Function AddByCoord (
XI As Double,
YI As Double,
ZI As Double,
XJ As Double,
YJ As Double,
ZJ As Double,
ByRef Name As String,
Optional IsSingleJoint As Boolean = false,
Optional PropName As String = "Default",
Optional UserName As String = "",
Optional CSys As String = "Global"
) As Integer
int AddByCoord(
double XI,
double YI,
double ZI,
double XJ,
double YJ,
double ZJ,
String^% Name,
bool IsSingleJoint = false,
String^ PropName = L"Default",
String^ UserName = L"",
String^ CSys = L"Global"
)
abstract AddByCoord :
XI : float *
YI : float *
ZI : float *
XJ : float *
YJ : float *
ZJ : float *
Name : string byref *
?IsSingleJoint : bool *
?PropName : string *
?UserName : string *
?CSys : string
(* Defaults:
let _IsSingleJoint = defaultArg IsSingleJoint false
let _PropName = defaultArg PropName "Default"
let _UserName = defaultArg UserName ""
let _CSys = defaultArg CSys "Global"
*)
-> int
Parameters
- XI
- Type: SystemDouble
The X coordinate of the I-End of the added link object
in the coordinate system defined by the CSys item. - YI
- Type: SystemDouble
The Y coordinate of the I-End of the added link object
in the coordinate system defined by the CSys item. - ZI
- Type: SystemDouble
The Z coordinate of the I-End of the added link object
in the coordinate system defined by the CSys item. - XJ
- Type: SystemDouble
The X coordinate of the J-End of the added link object
in the coordinate system defined by the CSys item. - YJ
- Type: SystemDouble
The Y coordinate of the J-End of the added link object
in the coordinate system defined by the CSys item. - ZJ
- Type: SystemDouble
The Z coordinate of the J-End of the added link object
in the coordinate system defined by the CSys item. - Name
- Type: SystemString
This is the name that the program ultimately assigns for the link object.
If no UserName is specified, the program assigns a default name to the
link object. If a UserName is specified and that name is not used for
another link object, the UserName is assigned to the link object;
otherwise a default name is assigned to the link object. - IsSingleJoint (Optional)
- Type: SystemBoolean
This item is True if a one-joint link is added and False
if a two-joint link is added. - PropName (Optional)
- Type: SystemString
This is either Default or the name of a defined link property.
If it is Default the program assigns a default link property to the link object.
If it is the name of a defined link property, that property is assigned to the link object
- UserName (Optional)
- Type: SystemString
- CSys (Optional)
- Type: SystemString
The name of the coordinate system in which the link object end point
coordinates are defined.
Return Value
Type:
Int32Returns zero if the link object is successfully added;
otherwise it returns a nonzero value.
RemarksOne-joint links are not supported in ETABS.
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name1 As String
Dim Name2 As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.LinkObj.AddByCoord(-288, 0, 288, 0, 0, 0, Name1, True)
ret = SapModel.LinkObj.AddByCoord(-288, 0, 0, 0, 0, 144, Name2)
ret = SapModel.View.RefreshView
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also