cAreaObjSetLoadUniform Method |
Assigns uniform loads to area objects.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetLoadUniform(
string Name,
string LoadPat,
double Value,
int Dir,
bool Replace = true,
string CSys = "Global",
eItemType ItemType = eItemType.Objects
)
Function SetLoadUniform (
Name As String,
LoadPat As String,
Value As Double,
Dir As Integer,
Optional Replace As Boolean = true,
Optional CSys As String = "Global",
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int SetLoadUniform(
String^ Name,
String^ LoadPat,
double Value,
int Dir,
bool Replace = true,
String^ CSys = L"Global",
eItemType ItemType = eItemType::Objects
)
abstract SetLoadUniform :
Name : string *
LoadPat : string *
Value : float *
Dir : int *
?Replace : bool *
?CSys : string *
?ItemType : eItemType
(* Defaults:
let _Replace = defaultArg Replace true
let _CSys = defaultArg CSys "Global"
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing area object or group, depending on the value
of the ItemType item.
- LoadPat
- Type: SystemString
The name of a defined load pattern.
- Value
- Type: SystemDouble
The uniform load value. [F/L2]
- Dir
- Type: SystemInt32
- Replace (Optional)
- Type: SystemBoolean
If this item is True, all previous uniform loads, if any, assigned to the
specified area object(s), in the specified load pattern, are deleted before
making the new assignment.
- CSys (Optional)
- Type: SystemString
This is Local or the name of a defined coordinate system, indicating the
coordinate system in which the uniform load is specified.
- ItemType (Optional)
- Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignment is made to the area object
specified by the Name item.
If this item is Group, the assignment is made to all area objects
in the group specified by the Name item.
If this item is SelectedObjects, assignment is made to all selected
area objects, and the Name item is ignored.
Return Value
Type:
Int32
Returns zero if the loads are successfully assigned;
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.AreaObj.SetLoadUniform("ALL", "DEAD", -0.01, 2, False, "Local", eItemType.Group)
ret = SapModel.View.RefreshView(0, False)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also