cDStAISC360_05_IBC2006GetPreference Method

Retrieves the value of a steel design preference item.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetPreference(
	int Item,
	ref double Value
)

Parameters

Item
Type: SystemInt32
This is an integer between 1 and 29, inclusive, indicating the preference item considered.
  1. Framing type
  2. Seismic design category
  3. Design provision
  4. Analysis method (Obsolete, replaced by 27, 28, and 29)
  5. Notional load coefficient
  6. Phi bending
  7. Phi compression
  8. Phi tension yielding
  9. Phi tension fracture
  10. Phi shear
  11. Phi shear sort webbed rolled I
  12. Phi torsion
  13. Ignore seismic code
  14. Ignore special seismic load
  15. Doubler plate is plug welded
  16. HSS welding type
  17. Reduce HSS thickness
  18. Consider deflection
  19. DL deflection limit, L/Value
  20. SDL + LL deflection limit, L/Value
  21. LL deflection limit, L/Value
  22. Total load deflection limit, L/Value
  23. Total camber limit, L/Value
  24. Pattern live load factor
  25. Demand/capacity ratio limit
  26. Multi-response case design
  27. Analysis Method
  28. Second Order Method
  29. Stiffness Reduction Method
Value
Type: SystemDouble
The value of the considered preference item.
  1. Framing type
    1. SMF
    2. IMF
    3. OMF
    4. SCBF
    5. OCBF
    6. OCBFI
    7. EBF
  2. Seismic design category
    1. A
    2. B
    3. C
    4. D
    5. E
    6. F
  3. Design provision
    1. LRFD
    2. ASD
  4. Analysis method (Obsolete, replaced by 27, 28, and 29)
    1. Gen 2nd Order Elastic
    2. 2nd Order By Amp 1st Order
    3. Limited 1st Order Elastic
    4. DAM Gen 2nd Order Taub Variable
    5. DAM Gen 2nd Order Taub Fixed
    6. DAM Amp 1st Order Taub Variable
    7. DAM Amp 1st Order Taub Fixed
  5. Notional load coefficient

    Value > 0

  6. Phi bending

    Value > 0

  7. Phi compression

    Value > 0

  8. Phi tension yielding

    Value > 0

  9. Phi tension fracture

    Value > 0

  10. Phi shear

    Value > 0

  11. Phi shear sort webbed rolled I

    Value > 0

  12. Phi torsion

    Value > 0

  13. Ignore seismic code

    0 = No

    Any other value = Yes

  14. Ignore special seismic load

    0 = No

    Any other value = Yes

  15. Doubler plate is plug welded

    0 = No

    Any other value = Yes

  16. HSS welding type
    1. ERW
    2. SAW
  17. Reduce HSS thickness

    0 = No

    Any other value = Yes

  18. Consider deflection

    0 = No

    Any other value = Yes

  19. DL deflection limit, L/Value

    Value > 0

  20. SDL + LL deflection limit, L/Value

    Value > 0

  21. LL deflection limit, L/Value

    Value > 0

  22. Total load deflection limit, L/Value

    Value > 0

  23. Total camber limit, L/Value

    Value > 0

  24. Pattern live load factor

    Value > 0

  25. Demand/capacity ratio limit

    Value > 0

  26. Multi-response case design
    1. Envelopes
    2. Step-by-step
    3. Last step
    4. Envelopes -- All
    5. Step-by-step -- All
  27. Analysis Method
    1. Direct Analysis
    2. Effective Length
    3. Limited 1st Order
  28. Second Order Method
    1. General 2nd Order
    2. Amplified 1st Order
  29. Stiffness Reduction Method
    1. Tau-b variable
    2. Tau-b Fixed
    3. No Modification

Return Value

Type: Int32
Returns zero if the item is successfully retrieved; otherwise it returns a nonzero value.
Remarks