cAutoSeismicGetIBC2006 Method

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetIBC2006(
	string Name,
	ref int DirFlag,
	ref double Eccen,
	ref int PeriodFlag,
	ref int CtType,
	ref double UserT,
	ref bool UserZ,
	ref double TopZ,
	ref double BottomZ,
	ref double R,
	ref double Omega,
	ref double Cd,
	ref double I,
	ref int IBC2006Option,
	ref double Latitude,
	ref double Longitude,
	ref string ZipCode,
	ref double Ss,
	ref double S1,
	ref double Tl,
	ref int SiteClass,
	ref double Fa,
	ref double Fv
)

Parameters

Name
Type: SystemString
DirFlag
Type: SystemInt32
Eccen
Type: SystemDouble
PeriodFlag
Type: SystemInt32
CtType
Type: SystemInt32
UserT
Type: SystemDouble
UserZ
Type: SystemBoolean
TopZ
Type: SystemDouble
BottomZ
Type: SystemDouble
R
Type: SystemDouble
Omega
Type: SystemDouble
Cd
Type: SystemDouble
I
Type: SystemDouble
IBC2006Option
Type: SystemInt32
Latitude
Type: SystemDouble
Longitude
Type: SystemDouble
ZipCode
Type: SystemString
Ss
Type: SystemDouble
S1
Type: SystemDouble
Tl
Type: SystemDouble
SiteClass
Type: SystemInt32
Fa
Type: SystemDouble
Fv
Type: SystemDouble

Return Value

Type: Int32
See Also