cAreaObjSetLocalAxes Method |
Assigns a local axis angle to area objects.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetLocalAxes(
string Name,
double Ang,
eItemType ItemType = eItemType.Objects
)
Function SetLocalAxes (
Name As String,
Ang As Double,
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int SetLocalAxes(
String^ Name,
double Ang,
eItemType ItemType = eItemType::Objects
)
abstract SetLocalAxes :
Name : string *
Ang : float *
?ItemType : eItemType
(* Defaults:
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing area object or group, depending on the value
of the ItemType item.
- Ang
- Type: SystemDouble
This is the angle that the local 1 and 2 axes are rotated about
the positive local 3 axis from the default orientation.
The rotation for a positive angle appears counter clockwise
when the local +3 axis is pointing toward you. [deg]
- ItemType (Optional)
- Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignment is made to the area object
specified by the Name item.
If this item is Group, the assignment is made to all area objects
in the group specified by the Name item.
If this item is SelectedObjects, assignment is made to all selected
area objects, and the Name item is ignored.
Return Value
Type:
Int32
Returns zero if the local axis angle is successfully assigned;
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.AreaObj.SetLocalAxes("3", 30)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also