cDetailingGetDetailedSlabTopBarData Method

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetDetailedSlabTopBarData(
	string SlabName,
	ref int NumData,
	ref string[] Names,
	ref int[] NumBars,
	ref double[] BarDiameter,
	ref string[] BarNotation,
	ref string[] BarMaterial,
	ref double[] StartX,
	ref double[] StartY,
	ref double[] StartZ,
	ref double[] EndX,
	ref double[] EndY,
	ref double[] EndZ,
	ref double[] WidthLeft,
	ref double[] WidthRight,
	ref double[] OffsetFromTop,
	ref double[] OffsetFromBot,
	ref int[] StartBarBend,
	ref int[] EndBarBend,
	ref string[] GUIDs
)

Parameters

SlabName
Type: SystemString
NumData
Type: SystemInt32
Names
Type: SystemString
NumBars
Type: SystemInt32
BarDiameter
Type: SystemDouble
BarNotation
Type: SystemString
BarMaterial
Type: SystemString
StartX
Type: SystemDouble
StartY
Type: SystemDouble
StartZ
Type: SystemDouble
EndX
Type: SystemDouble
EndY
Type: SystemDouble
EndZ
Type: SystemDouble
WidthLeft
Type: SystemDouble
WidthRight
Type: SystemDouble
OffsetFromTop
Type: SystemDouble
OffsetFromBot
Type: SystemDouble
StartBarBend
Type: SystemInt32
EndBarBend
Type: SystemInt32
GUIDs
Type: SystemString

Return Value

Type: Int32
See Also