cPropLinkCount Method

Returns the total number of defined link properties in the model. If desired, counts can be returned for all link properties of a specified type in the model.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int Count(
	eLinkPropType PropType = 
)

Parameters

PropType (Optional)
Type: ETABS2016eLinkPropType
This optional value is one of the items in the eLinkPropType enumeration. If no value is input for PropType, a count is returned for all link properties in the model regardless of type.

Return Value

Type: Int32
Returns the total number of defined link properties in the model.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim DOF() As Boolean
       Dim Fixed() As Boolean
       Dim Ke() As Double
       Dim Ce() As Double
       Dim Count As Integer

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'add link property
       ReDim DOF(5)
       ReDim Fixed(5)
       ReDim Ke(5)
       ReDim Ce(5)
       DOF(0) = True
       Ke(0) = 12
       ret = SapModel.PropLink.SetLinear("L1", DOF, Fixed, Ke, Ce, 0, 0)

   'return number of defined links of all types
       Count = SapModel.PropLink.Count

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also