cCaseStaticNonlinearStagedGetStageDefinitions_1 Method |
Retrieves the stage definition data for the specified load case
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetStageDefinitions_1(
string Name,
ref int NumberStages,
ref int[] Duration,
ref bool[] Output,
ref string[] OutputName,
ref string[] Comment
)
Function GetStageDefinitions_1 (
Name As String,
ByRef NumberStages As Integer,
ByRef Duration As Integer(),
ByRef Output As Boolean(),
ByRef OutputName As String(),
ByRef Comment As String()
) As Integer
int GetStageDefinitions_1(
String^ Name,
int% NumberStages,
array<int>^% Duration,
array<bool>^% Output,
array<String^>^% OutputName,
array<String^>^% Comment
)
abstract GetStageDefinitions_1 :
Name : string *
NumberStages : int byref *
Duration : int[] byref *
Output : bool[] byref *
OutputName : string[] byref *
Comment : string[] byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing static nonlinear staged load case
- NumberStages
- Type: SystemInt32
The number of stages defined for the specified load case
- Duration
- Type: SystemInt32
This is an array that includes the duration in days for each stage
- Output
- Type: SystemBoolean
This is an array that includes True or False,
indicating if analysis output is to be saved for each stage
- OutputName
- Type: SystemString
This is an array that includes a user-specified output name for each stage
- Comment
- Type: SystemString
This is an array that includes a comment for each stage.
The comment may be a blank string.
Return Value
Type:
Int32
Returns zero if the data is successfully retrieved; otherwise it returns a nonzero value
Remarks
See Also