cDetailingGetColumnLongRebarData Method

Retrieves longitudinal rebar data for a column frame object

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetColumnLongRebarData(
	string Name,
	ref int NumberRebarSets,
	ref string[] BarSizeName,
	ref double[] BarArea,
	ref int[] NumberCBars,
	ref int[] NumberR3Bars,
	ref int[] NumberR2Bars,
	ref string[] Location,
	ref double[] ClearCover,
	ref string[] RebarSetGUID
)

Parameters

Name
Type: SystemString
The name of an existing beam frame object
NumberRebarSets
Type: SystemInt32
Number of longitudinal rebar sets for this beam object
BarSizeName
Type: SystemString
Rebar designation
BarArea
Type: SystemDouble
Individual rebar area
NumberCBars
Type: SystemInt32
Total number of rebars in this set (for both circular or rectangular pattern)
NumberR3Bars
Type: SystemInt32
Number of rectangular pattern bars along 3 direction (per face including corner bars); zero for circular pattern
NumberR2Bars
Type: SystemInt32
Number of rectangular pattern bars along 2 direction (per face including corner bars); zero for circular pattern
Location
Type: SystemString
Location of this set of rebars - not currenlty used - left initilaized to blank ""
ClearCover
Type: SystemDouble
Clear cover from face to longitudinal rebar being specified
RebarSetGUID
Type: SystemString
The GUIDs of each of the rebar sets

Return Value

Type: Int32
Returns zero if the rebar data is successfully retrieved; otherwise it returns a nonzero value.
See Also