cLoadCasesGetTypeOAPI_1 Method

Retrieves the case type, design type, and auto flag for the specified load case

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetTypeOAPI_1(
	string Name,
	ref eLoadCaseType CaseType,
	ref int SubType,
	ref eLoadPatternType DesignType,
	ref int DesignTypeOption,
	ref int Auto
)

Parameters

Name
Type: SystemString
The name of an existing load case
CaseType
Type: ETABS2016eLoadCaseType
This is one of the items in the eLoadCaseType enumeration
SubType
Type: SystemInt32
This is an integer representing the load case sub type. This item applies only for certain case types.

For NonlinearStatic

  1. Nonlinear
  2. Nonlinear staged construction

For Modal

  1. Eigen
  2. Ritz

For LinearHistory

  1. Transient
  2. Periodic
DesignType
Type: ETABS2016eLoadPatternType
This is one of the items in the eLoadPatternType enumeration
DesignTypeOption
Type: SystemInt32
This is one of the following options for the DesignType item

0 = Program determined

1 = User specified

Auto
Type: SystemInt32
This is one of the following values indicating if the load case has been automatically created

0 = Not automatically created

1 = Automatically created

Return Value

Type: Int32
Returns zero if the type is successfully retrieved; otherwise it returns nonzero
Remarks
See Also