Retrieves the story information for the current tower
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetStories(
ref int NumberStories,
ref string[] StoryNames,
ref double[] StoryElevations,
ref double[] StoryHeights,
ref bool[] IsMasterStory,
ref string[] SimilarToStory,
ref bool[] SpliceAbove,
ref double[] SpliceHeight
)
Function GetStories (
ByRef NumberStories As Integer,
ByRef StoryNames As String(),
ByRef StoryElevations As Double(),
ByRef StoryHeights As Double(),
ByRef IsMasterStory As Boolean(),
ByRef SimilarToStory As String(),
ByRef SpliceAbove As Boolean(),
ByRef SpliceHeight As Double()
) As Integer
int GetStories(
int% NumberStories,
array<String^>^% StoryNames,
array<double>^% StoryElevations,
array<double>^% StoryHeights,
array<bool>^% IsMasterStory,
array<String^>^% SimilarToStory,
array<bool>^% SpliceAbove,
array<double>^% SpliceHeight
)
abstract GetStories :
NumberStories : int byref *
StoryNames : string[] byref *
StoryElevations : float[] byref *
StoryHeights : float[] byref *
IsMasterStory : bool[] byref *
SimilarToStory : string[] byref *
SpliceAbove : bool[] byref *
SpliceHeight : float[] byref -> int
Parameters
- NumberStories
- Type: SystemInt32
The number of stories. All output arrays have length (NumberStories + 1), because
they include values for "Base" , which is not a story.
- StoryNames
- Type: SystemString
The names of the stories. This array will include "Base" .
- StoryElevations
- Type: SystemDouble
The story elevations. The first value is the "Base" elevation.
- StoryHeights
- Type: SystemDouble
The story heights. The first value is the "Base" height.
- IsMasterStory
- Type: SystemBoolean
Whether the story is a master story
- SimilarToStory
- Type: SystemString
If the story is not a master story, which master story the story is similar to
- SpliceAbove
- Type: SystemBoolean
This is True if the story has a splice height, and False otherwise
- SpliceHeight
- Type: SystemDouble
The story splice height
Return Value
Type:
Int32
Returns zero if the story data is successfully retrieved,
otherwise returns nonzero.
Remarks
To change the current tower, use
SetActiveTower(String)
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim NumberStories As Integer
Dim StoryNames() As String
Dim StoryHeights() As Double
Dim StoryElevations() As Double
Dim IsMasterStory() As Boolean
Dim SimilarToStory() As String
Dim SpliceAbove() As Boolean
Dim SpliceHeight() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.Story.GetStories(NumberStories, StoryNames, StoryHeights, StoryElevations, _
IsMasterStory, SimilarToStory, SpliceAbove, SpliceHeight)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also