cPointElmGetLoadForce Method |
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetLoadForce(
string Name,
ref int NumberItems,
ref string[] PointName,
ref string[] LoadPat,
ref int[] LcStep,
ref string[] CSys,
ref double[] F1,
ref double[] F2,
ref double[] F3,
ref double[] M1,
ref double[] M2,
ref double[] M3,
eItemTypeElm ItemTypeElm = eItemTypeElm.Element
)
Function GetLoadForce (
Name As String,
ByRef NumberItems As Integer,
ByRef PointName As String(),
ByRef LoadPat As String(),
ByRef LcStep As Integer(),
ByRef CSys As String(),
ByRef F1 As Double(),
ByRef F2 As Double(),
ByRef F3 As Double(),
ByRef M1 As Double(),
ByRef M2 As Double(),
ByRef M3 As Double(),
Optional ItemTypeElm As eItemTypeElm = eItemTypeElm.Element
) As Integer
int GetLoadForce(
String^ Name,
int% NumberItems,
array<String^>^% PointName,
array<String^>^% LoadPat,
array<int>^% LcStep,
array<String^>^% CSys,
array<double>^% F1,
array<double>^% F2,
array<double>^% F3,
array<double>^% M1,
array<double>^% M2,
array<double>^% M3,
eItemTypeElm ItemTypeElm = eItemTypeElm::Element
)
abstract GetLoadForce :
Name : string *
NumberItems : int byref *
PointName : string[] byref *
LoadPat : string[] byref *
LcStep : int[] byref *
CSys : string[] byref *
F1 : float[] byref *
F2 : float[] byref *
F3 : float[] byref *
M1 : float[] byref *
M2 : float[] byref *
M3 : float[] byref *
?ItemTypeElm : eItemTypeElm
(* Defaults:
let _ItemTypeElm = defaultArg ItemTypeElm eItemTypeElm.Element
*)
-> int
Parameters
- Name
- Type: SystemString
- NumberItems
- Type: SystemInt32
- PointName
- Type: SystemString
- LoadPat
- Type: SystemString
- LcStep
- Type: SystemInt32
- CSys
- Type: SystemString
- F1
- Type: SystemDouble
- F2
- Type: SystemDouble
- F3
- Type: SystemDouble
- M1
- Type: SystemDouble
- M2
- Type: SystemDouble
- M3
- Type: SystemDouble
- ItemTypeElm (Optional)
- Type: ETABS2016eItemTypeElm
Return Value
Type:
Int32
See Also