cDetailingGetDetailedSlabBotBarData Method |
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetDetailedSlabBotBarData(
string SlabName,
ref int NumData,
ref string[] Names,
ref int[] NumBars,
ref double[] BarDiameter,
ref string[] BarNotation,
ref string[] BarMaterial,
ref double[] StartX,
ref double[] StartY,
ref double[] StartZ,
ref double[] EndX,
ref double[] EndY,
ref double[] EndZ,
ref double[] WidthLeft,
ref double[] WidthRight,
ref double[] OffsetFromTop,
ref double[] OffsetFromBot,
ref int[] StartBarBend,
ref int[] EndBarBend,
ref string[] GUIDs
)
Function GetDetailedSlabBotBarData (
SlabName As String,
ByRef NumData As Integer,
ByRef Names As String(),
ByRef NumBars As Integer(),
ByRef BarDiameter As Double(),
ByRef BarNotation As String(),
ByRef BarMaterial As String(),
ByRef StartX As Double(),
ByRef StartY As Double(),
ByRef StartZ As Double(),
ByRef EndX As Double(),
ByRef EndY As Double(),
ByRef EndZ As Double(),
ByRef WidthLeft As Double(),
ByRef WidthRight As Double(),
ByRef OffsetFromTop As Double(),
ByRef OffsetFromBot As Double(),
ByRef StartBarBend As Integer(),
ByRef EndBarBend As Integer(),
ByRef GUIDs As String()
) As Integer
int GetDetailedSlabBotBarData(
String^ SlabName,
int% NumData,
array<String^>^% Names,
array<int>^% NumBars,
array<double>^% BarDiameter,
array<String^>^% BarNotation,
array<String^>^% BarMaterial,
array<double>^% StartX,
array<double>^% StartY,
array<double>^% StartZ,
array<double>^% EndX,
array<double>^% EndY,
array<double>^% EndZ,
array<double>^% WidthLeft,
array<double>^% WidthRight,
array<double>^% OffsetFromTop,
array<double>^% OffsetFromBot,
array<int>^% StartBarBend,
array<int>^% EndBarBend,
array<String^>^% GUIDs
)
abstract GetDetailedSlabBotBarData :
SlabName : string *
NumData : int byref *
Names : string[] byref *
NumBars : int[] byref *
BarDiameter : float[] byref *
BarNotation : string[] byref *
BarMaterial : string[] byref *
StartX : float[] byref *
StartY : float[] byref *
StartZ : float[] byref *
EndX : float[] byref *
EndY : float[] byref *
EndZ : float[] byref *
WidthLeft : float[] byref *
WidthRight : float[] byref *
OffsetFromTop : float[] byref *
OffsetFromBot : float[] byref *
StartBarBend : int[] byref *
EndBarBend : int[] byref *
GUIDs : string[] byref -> int
Parameters
- SlabName
- Type: SystemString
- NumData
- Type: SystemInt32
- Names
- Type: SystemString
- NumBars
- Type: SystemInt32
- BarDiameter
- Type: SystemDouble
- BarNotation
- Type: SystemString
- BarMaterial
- Type: SystemString
- StartX
- Type: SystemDouble
- StartY
- Type: SystemDouble
- StartZ
- Type: SystemDouble
- EndX
- Type: SystemDouble
- EndY
- Type: SystemDouble
- EndZ
- Type: SystemDouble
- WidthLeft
- Type: SystemDouble
- WidthRight
- Type: SystemDouble
- OffsetFromTop
- Type: SystemDouble
- OffsetFromBot
- Type: SystemDouble
- StartBarBend
- Type: SystemInt32
- EndBarBend
- Type: SystemInt32
- GUIDs
- Type: SystemString
Return Value
Type:
Int32
See Also