cAreaObjGetAllAreas Method |
Retrieves select data for all area objects in the model
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetAllAreas(
ref int NumberNames,
ref string[] MyName,
ref eAreaDesignOrientation[] DesignOrientation,
ref int NumberBoundaryPts,
ref int[] PointDelimiter,
ref string[] PointNames,
ref double[] PointX,
ref double[] PointY,
ref double[] PointZ
)
Function GetAllAreas (
ByRef NumberNames As Integer,
ByRef MyName As String(),
ByRef DesignOrientation As eAreaDesignOrientation(),
ByRef NumberBoundaryPts As Integer,
ByRef PointDelimiter As Integer(),
ByRef PointNames As String(),
ByRef PointX As Double(),
ByRef PointY As Double(),
ByRef PointZ As Double()
) As Integer
int GetAllAreas(
int% NumberNames,
array<String^>^% MyName,
array<eAreaDesignOrientation>^% DesignOrientation,
int% NumberBoundaryPts,
array<int>^% PointDelimiter,
array<String^>^% PointNames,
array<double>^% PointX,
array<double>^% PointY,
array<double>^% PointZ
)
abstract GetAllAreas :
NumberNames : int byref *
MyName : string[] byref *
DesignOrientation : eAreaDesignOrientation[] byref *
NumberBoundaryPts : int byref *
PointDelimiter : int[] byref *
PointNames : string[] byref *
PointX : float[] byref *
PointY : float[] byref *
PointZ : float[] byref -> int
Parameters
- NumberNames
- Type: SystemInt32
- MyName
- Type: SystemString
- DesignOrientation
- Type: ETABS2016eAreaDesignOrientation
- NumberBoundaryPts
- Type: SystemInt32
- PointDelimiter
- Type: SystemInt32
- PointNames
- Type: SystemString
- PointX
- Type: SystemDouble
- PointY
- Type: SystemDouble
- PointZ
- Type: SystemDouble
Return Value
Type:
Int32
Remarks
See Also