cCaseStaticNonlinearGetSolControlParameters Method

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetSolControlParameters(
	string Name,
	ref int MaxTotalSteps,
	ref int MaxFailedSubSteps,
	ref int MaxIterCS,
	ref int MaxIterNR,
	ref double TolConvD,
	ref bool UseEventStepping,
	ref double TolEventD,
	ref int MaxLineSearchPerIter,
	ref double TolLineSearch,
	ref double LineSearchStepFact
)

Parameters

Name
Type: SystemString
MaxTotalSteps
Type: SystemInt32
MaxFailedSubSteps
Type: SystemInt32
MaxIterCS
Type: SystemInt32
MaxIterNR
Type: SystemInt32
TolConvD
Type: SystemDouble
UseEventStepping
Type: SystemBoolean
TolEventD
Type: SystemDouble
MaxLineSearchPerIter
Type: SystemInt32
TolLineSearch
Type: SystemDouble
LineSearchStepFact
Type: SystemDouble

Return Value

Type: Int32
See Also