cDesignConcreteGetSummaryResultsJoint Method |
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetSummaryResultsJoint(
string Name,
ref int NumberItems,
ref string[] FrameName,
ref string[] LCJSRatioMajor,
ref double[] JSRatioMajor,
ref string[] LCJSRatioMinor,
ref double[] JSRatioMinor,
ref string[] LCBCCRatioMajor,
ref double[] BCCRatioMajor,
ref string[] LCBCCRatioMinor,
ref double[] BCCRatioMinor,
ref string[] ErrorSummary,
ref string[] WarningSummary,
eItemType ItemType = eItemType.Objects
)
Function GetSummaryResultsJoint (
Name As String,
ByRef NumberItems As Integer,
ByRef FrameName As String(),
ByRef LCJSRatioMajor As String(),
ByRef JSRatioMajor As Double(),
ByRef LCJSRatioMinor As String(),
ByRef JSRatioMinor As Double(),
ByRef LCBCCRatioMajor As String(),
ByRef BCCRatioMajor As Double(),
ByRef LCBCCRatioMinor As String(),
ByRef BCCRatioMinor As Double(),
ByRef ErrorSummary As String(),
ByRef WarningSummary As String(),
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int GetSummaryResultsJoint(
String^ Name,
int% NumberItems,
array<String^>^% FrameName,
array<String^>^% LCJSRatioMajor,
array<double>^% JSRatioMajor,
array<String^>^% LCJSRatioMinor,
array<double>^% JSRatioMinor,
array<String^>^% LCBCCRatioMajor,
array<double>^% BCCRatioMajor,
array<String^>^% LCBCCRatioMinor,
array<double>^% BCCRatioMinor,
array<String^>^% ErrorSummary,
array<String^>^% WarningSummary,
eItemType ItemType = eItemType::Objects
)
abstract GetSummaryResultsJoint :
Name : string *
NumberItems : int byref *
FrameName : string[] byref *
LCJSRatioMajor : string[] byref *
JSRatioMajor : float[] byref *
LCJSRatioMinor : string[] byref *
JSRatioMinor : float[] byref *
LCBCCRatioMajor : string[] byref *
BCCRatioMajor : float[] byref *
LCBCCRatioMinor : string[] byref *
BCCRatioMinor : float[] byref *
ErrorSummary : string[] byref *
WarningSummary : string[] byref *
?ItemType : eItemType
(* Defaults:
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
- NumberItems
- Type: SystemInt32
- FrameName
- Type: SystemString
- LCJSRatioMajor
- Type: SystemString
- JSRatioMajor
- Type: SystemDouble
- LCJSRatioMinor
- Type: SystemString
- JSRatioMinor
- Type: SystemDouble
- LCBCCRatioMajor
- Type: SystemString
- BCCRatioMajor
- Type: SystemDouble
- LCBCCRatioMinor
- Type: SystemString
- BCCRatioMinor
- Type: SystemDouble
- ErrorSummary
- Type: SystemString
- WarningSummary
- Type: SystemString
- ItemType (Optional)
- Type: ETABS2016eItemType
Return Value
Type:
Int32
See Also