cLinkObjSetGroupAssign Method

Adds/removes link objects to/from a specified group.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetGroupAssign(
	string Name,
	string GroupName,
	bool Remove = false,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: SystemString
The name of an existing link object or group, depending on the value of the ItemType item.
GroupName
Type: SystemString
The name of an existing group to which the assignment is made.
Remove (Optional)
Type: SystemBoolean
ItemType (Optional)
Type: ETABS2016eItemType
This is one of the items in the eItemType enumeration.

If this item is Objects, the link object specified by the Name item is added/removed to/from the group specified by the GroupName item.

If this item is Group, the link objects in the group specified by the Name item is added/removed to/from the group specified by the GroupName item.

If this item is SelectedObjects, all selected link objects are added/removed to/from the group specified by the GroupName item, and the Name item is ignored.

Return Value

Type: Int32
Returns zero if the group assignment is successful; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim Name As String

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'add link object by points
       ret = SapModel.LinkObj.AddByPoint("1", "5", Name)

   'define new group
       ret = SapModel.GroupDef.SetGroup("Group1")

   'add link object to group
       ret = SapModel.LinkObj.SetGroupAssign(Name, "Group1")

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also