cPropLinkGetTypeOAPI Method

Retrieves the property type for the specified link property.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetTypeOAPI(
	string Name,
	ref eLinkPropType PropType
)

Parameters

Name
Type: SystemString
The name of an existing link property.
PropType
Type: ETABS2016eLinkPropType
This is one of the items in the eLinkPropType enumeration.

Return Value

Type: Int32
Returns zero if the type is successfully retrieved; otherwise it returns nonzero.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim DOF() As Boolean
       Dim Fixed() As Boolean
       Dim Ke() As Double
       Dim Ce() As Double
       Dim PropType As eLinkPropType

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'add link property
       ReDim DOF(5)
       ReDim Fixed(5)
       ReDim Ke(5)
       ReDim Ce(5)
       DOF(0) = True
       Ke(0) = 12
       ret = SapModel.PropLink.SetLinear("L1", DOF, Fixed, Ke, Ce, 0, 0)

   'get link property type
       ret = SapModel.PropLink.GetTypeOAPI("L1", PropType)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also