Retrieves the group data.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetGroup(
string Name,
ref int Color,
ref bool SpecifiedForSelection,
ref bool SpecifiedForSectionCutDefinition,
ref bool SpecifiedForSteelDesign,
ref bool SpecifiedForConcreteDesign,
ref bool SpecifiedForAluminumDesign,
ref bool SpecifiedForColdFormedDesign,
ref bool SpecifiedForStaticNLActiveStage,
ref bool SpecifiedForBridgeResponseOutput,
ref bool SpecifiedForAutoSeismicOutput,
ref bool SpecifiedForAutoWindOutput,
ref bool SpecifiedForMassAndWeight
)
Function GetGroup (
Name As String,
ByRef Color As Integer,
ByRef SpecifiedForSelection As Boolean,
ByRef SpecifiedForSectionCutDefinition As Boolean,
ByRef SpecifiedForSteelDesign As Boolean,
ByRef SpecifiedForConcreteDesign As Boolean,
ByRef SpecifiedForAluminumDesign As Boolean,
ByRef SpecifiedForColdFormedDesign As Boolean,
ByRef SpecifiedForStaticNLActiveStage As Boolean,
ByRef SpecifiedForBridgeResponseOutput As Boolean,
ByRef SpecifiedForAutoSeismicOutput As Boolean,
ByRef SpecifiedForAutoWindOutput As Boolean,
ByRef SpecifiedForMassAndWeight As Boolean
) As Integer
int GetGroup(
String^ Name,
int% Color,
bool% SpecifiedForSelection,
bool% SpecifiedForSectionCutDefinition,
bool% SpecifiedForSteelDesign,
bool% SpecifiedForConcreteDesign,
bool% SpecifiedForAluminumDesign,
bool% SpecifiedForColdFormedDesign,
bool% SpecifiedForStaticNLActiveStage,
bool% SpecifiedForBridgeResponseOutput,
bool% SpecifiedForAutoSeismicOutput,
bool% SpecifiedForAutoWindOutput,
bool% SpecifiedForMassAndWeight
)
abstract GetGroup :
Name : string *
Color : int byref *
SpecifiedForSelection : bool byref *
SpecifiedForSectionCutDefinition : bool byref *
SpecifiedForSteelDesign : bool byref *
SpecifiedForConcreteDesign : bool byref *
SpecifiedForAluminumDesign : bool byref *
SpecifiedForColdFormedDesign : bool byref *
SpecifiedForStaticNLActiveStage : bool byref *
SpecifiedForBridgeResponseOutput : bool byref *
SpecifiedForAutoSeismicOutput : bool byref *
SpecifiedForAutoWindOutput : bool byref *
SpecifiedForMassAndWeight : bool byref -> int
Parameters
- Name
- Type: SystemString
This is the name of an existing group. - Color
- Type: SystemInt32
- SpecifiedForSelection
- Type: SystemBoolean
This item is True if the group is specified to be
used for selection; otherwise it is False. - SpecifiedForSectionCutDefinition
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining section cuts; otherwise it is False. - SpecifiedForSteelDesign
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining steel frame design groups; otherwise it is False. - SpecifiedForConcreteDesign
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining concrete frame design groups; otherwise it is False. - SpecifiedForAluminumDesign
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining aluminum frame design groups; otherwise it is False. - SpecifiedForColdFormedDesign
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining cold formed frame design groups; otherwise it is False. - SpecifiedForStaticNLActiveStage
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining stages for nonlinear static analysis; otherwise it is False. - SpecifiedForBridgeResponseOutput
- Type: SystemBoolean
This item is True if the group is specified to be
used for reporting bridge response output; otherwise it is False. - SpecifiedForAutoSeismicOutput
- Type: SystemBoolean
This item is True if the group is specified to be
used for reporting auto seismic loads; otherwise it is False. - SpecifiedForAutoWindOutput
- Type: SystemBoolean
This item is True if the group is specified to be
used for reporting auto wind loads; otherwise it is False. - SpecifiedForMassAndWeight
- Type: SystemBoolean
This item is True if the group is specified to be
used for reporting group masses and weight; otherwise it is False.
Return Value
Type:
Int32Returns zero if the group data is successfully set;
otherwise it returns a nonzero value.
RemarksItems
SpecifiedForAluminumDesign,
SpecifiedForColdFormedDesignSpecifiedForBridgeResponseOutput are not supported in ETABS.
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Color as Integer
Dim SpecifiedForSelection as Boolean
Dim SpecifiedForSectionCutDefinition as Boolean
Dim SpecifiedForSteelDesign as Boolean
Dim SpecifiedForConcreteDesign as Boolean
Dim SpecifiedForAluminumDesign as Boolean
Dim SpecifiedForColdFormedDesign as Boolean
Dim SpecifiedForStaticNLActiveStage as Boolean
Dim SpecifiedForBridgeResponseOutput as Boolean
Dim SpecifiedForAutoSeismicOutput as Boolean
Dim SpecifiedForAutoWindOutput as Boolean
Dim SpecifiedForMassAndWeight as Boolean
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.GroupDef.SetGroup("Group1", -1, True)
ret = SapModel.GroupDef.GetGroup("Group1", Color, SpecifiedForSelection, SpecifiedForSectionCutDefinition, SpecifiedForSteelDesign, SpecifiedForConcreteDesign, SpecifiedForAluminumDesign, SpecifiedForColdFormedDesign, SpecifiedForStaticNLActiveStage, SpecifiedForBridgeResponseOutput, SpecifiedForAutoSeismicOutput, SpecifiedForAutoWindOutput, SpecifiedForMassAndWeight)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also