cPropLinkGetRubberIsolator Method

retrieves link property data for a rubber isolator-type link property.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetRubberIsolator(
	string Name,
	ref bool[] DOF,
	ref bool[] Fixed,
	ref bool[] Nonlinear,
	ref double[] Ke,
	ref double[] Ce,
	ref double[] K,
	ref double[] Yield,
	ref double[] Ratio,
	ref double DJ2,
	ref double DJ3,
	ref string Notes,
	ref string GUID
)

Parameters

Name
Type: SystemString
The name of an existing rubber isolator-type link property.
DOF
Type: SystemBoolean
Fixed
Type: SystemBoolean
This is a boolean array, dimensioned to 5, indicating if the specified degree of freedom is fixed (restrained).
ValueFixity
Fixed(0)U1 fixity if DOF(0) = True
Fixed(1)U2 fixity if DOF(1) = True
Fixed(2)U3 fixity if DOF(2) = True
Fixed(3)R1 fixity if DOF(3) = True
Fixed(4)R2 fixity if DOF(4) = True
Fixed(5)R3 fixity if DOF(5) = True
Nonlinear
Type: SystemBoolean
This is a boolean array, dimensioned to 5, indicating if nonlinear properties exist for a specified degree of freedom.
ValueNonlinear
Nonlinear(0)U1 has nonlinear properties
Nonlinear(1)U2 has nonlinear properties
Nonlinear(2)U3 has nonlinear properties
Nonlinear(3)R1, not used
Nonlinear(4)R2, not used
Nonlinear(5)R3, not used

Note that this item is applicable only for degrees of freedom U1, U2 and U3. For those degrees of freedom, the term Nonlinear(n) applies only when DOF(n) = True and Fixed(n) = False.

Ke
Type: SystemDouble
Ce
Type: SystemDouble
K
Type: SystemDouble
Yield
Type: SystemDouble
This is an array of yield force terms for the link property. The yield force applies for nonlinear analyses.
ValueYield
yield(0)U1, not used
yield(1)U2 [F]
yield(2)U3 [F]
yield(3)R1, not used
yield(4)R2, not used
yield(5)R3, not used

Note that this item is applicable only for degrees of freedom U2 and U3. For those degrees of freedom, the term Yield(n) applies only when DOF(n) = True, Fixed(n) = False, and Nonlinear(n) = True.

Ratio
Type: SystemDouble
This is an array of post-yield stiffness ratio terms for the link property. The post-yield stiffness ratio applies for nonlinear analyses. It is the post-yield stiffness divided by the initial stiffness.
ValueRatio
Ratio(0)U1, not used
Ratio(1)U2
Ratio(2)U3
Ratio(3)R1, not used
Ratio(4)R2, not used
Ratio(5)R3, not used

Note that this item is applicable only for degrees of freedom U2 and U3. For those degrees of freedom, the term Ratio(n) applies only when DOF(n) = True, Fixed(n) = False, and Nonlinear(n) = True.

DJ2
Type: SystemDouble
DJ3
Type: SystemDouble
Notes
Type: SystemString
GUID
Type: SystemString
The GUID (global unique identifier), if any, assigned to the property.

Return Value

Type: Int32
Returns zero if the property is successfully retrieved; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim MyDOF() As Boolean
       Dim MyFixed() As Boolean
       Dim MyNonLinear() as Boolean
       Dim MyKe() As Double
       Dim MyCe() As Double
       Dim MyK() As Double
       Dim MyYield() As Double
       Dim MyRatio() As Double
       Dim DOF() As Boolean
       Dim Fixed() As Boolean
       Dim NonLinear() as Boolean
       Dim Ke() As Double
       Dim Ce() As Double
       Dim K() As Double
       Dim Yield() As Double
       Dim Ratio() As Double
       Dim dj2 As Double
       Dim dj3 As Double
       Dim Notes As String
       Dim GUID As String

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'add link property
       ReDim MyDOF(5)
       ReDim MyFixed(5)
       ReDim MyNonLinear(5)
       ReDim MyKe(5)
       ReDim MyCe(5)
       ReDim MyK(5)
       ReDim MyYield(5)
       ReDim MyRatio(5)

       MyDOF(0) = True
       MyKe(0) = 12
       MyCe(0) = 0.01

       MyDOF(1) = True
       MyNonLinear(1) = True
       MyKe(1) = 12
       MyCe(1) = 0.01
       MyK(1) = 20
       MyYield(1)= 50
       MyRatio(1)= 0.1

       MyDOF(2) = True
       MyNonLinear(2) = True
       MyKe(2) = 15
       MyCe(2) = 0.008
       MyK(2) = 22
       MyYield(2)= 60
       MyRatio(2)= 0.15

       MyDOF(3) = True
       MyFixed(3) = True

       ret = SapModel.PropLink.SetRubberIsolator("RI1", MyDOF, MyFixed, MyNonLinear, MyKe, MyCe, MyK, MyYield, MyRatio, 2, 3)

   'get link property data
       ret = SapModel.PropLink.GetRubberIsolator("RI1", DOF, Fixed, NonLinear, Ke, Ce, k, Yield, Ratio, dj2, dj3, Notes, GUID)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also