cAreaObjGetOpening Method

Retrieves whether the specified area object is an opening.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetOpening(
	string Name,
	ref bool IsOpening
)

Parameters

Name
Type: SystemString
The name of a defined area object.
IsOpening
Type: SystemBoolean
This item is True if the specified area object is an opening, otherwise it is False.

Return Value

Type: Int32
The function returns zero if the assignment is successfully retrieved; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
   Dim SapModel As cSapModel
   Dim EtabsObject As cOAPI
   Dim ret As Integer = -1
   Dim IsOpening as Boolean

'create ETABS object
   EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

'start ETABS application
  ret = EtabsObject.ApplicationStart()

'create SapModel object
   SapModel = EtabsObject.SapModel

'initialize model
   ret = SapModel.InitializeNewModel()

'create steel deck template model
   ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

'designate an area object as an opening
   ret = SapModel.AreaObj.SetOpening("3", True)

'retrieve whether area object is an opening
   ret = SapModel.AreaObj.GetOpening("3", IsOpening)

'close ETABS
   EtabsObject.ApplicationExit(False)

'clean up variables
   SapModel = Nothing
   EtabsObject = Nothing

End Sub
See Also