cFileSave Method

Saves the present model.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int Save(
	string FileName = ""
)

Parameters

FileName (Optional)
Type: SystemString
The full path to which the model file is saved.

Return Value

Type: Int32
Returns zero if the file is successfully saved and nonzero if it is not saved.
Remarks
If no file name is specified, the file is saved using its current name. If there is no current name for the file (the file has not been saved previously) and this function is called with no file name specified, an error will be returned.
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'save file
       System.IO.Directory.CreateDirectory("c:\CSI_API_temp")
       ret = SapModel.File.Save("C:\CSI_API_temp\example.edb")

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also