cLinkObjGetLocalAxes Method

Retrieves the local axis angle assignment for link objects.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetLocalAxes(
	string Name,
	ref double Ang,
	ref bool Advanced
)

Parameters

Name
Type: SystemString
The name of an existing link object.
Ang
Type: SystemDouble
This is the angle that the local 2 and 3 axes are rotated about the positive local 1 axis, from the default orientation. The rotation for a positive angle appears counter clockwise when the local +1 axis is pointing toward you. [deg].
Advanced
Type: SystemBoolean
This item is True if the link object local axes orientation was obtained using advanced local axes parameters.

Return Value

Type: Int32
Returns zero if the assignment is successfully retrieved; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim Name As String
       Dim Ang As Double
       Dim Advanced As boolean

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'add link object by points
       ret = SapModel.LinkObj.AddByPoint("1", "5", Name)

   'assign link local axis angle
       ret = SapModel.LinkObj.SetLocalAxes(Name, 30)

   'get link local axis angle
       ret = SapModel.LinkObj.GetLocalAxes(Name, Ang, Advanced)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also