cAutoSeismicSetIBC2006 Method |
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetIBC2006(
string Name,
int DirFlag,
double Eccen,
int PeriodFlag,
int CtType,
double UserT,
bool UserZ,
double TopZ,
double BottomZ,
double R,
double Omega,
double Cd,
double I,
int IBC2006Option,
double Latitude,
double Longitude,
string ZipCode,
double Ss,
double S1,
double Tl,
int SiteClass,
double Fa,
double Fv
)
Function SetIBC2006 (
Name As String,
DirFlag As Integer,
Eccen As Double,
PeriodFlag As Integer,
CtType As Integer,
UserT As Double,
UserZ As Boolean,
TopZ As Double,
BottomZ As Double,
R As Double,
Omega As Double,
Cd As Double,
I As Double,
IBC2006Option As Integer,
Latitude As Double,
Longitude As Double,
ZipCode As String,
Ss As Double,
S1 As Double,
Tl As Double,
SiteClass As Integer,
Fa As Double,
Fv As Double
) As Integer
int SetIBC2006(
String^ Name,
int DirFlag,
double Eccen,
int PeriodFlag,
int CtType,
double UserT,
bool UserZ,
double TopZ,
double BottomZ,
double R,
double Omega,
double Cd,
double I,
int IBC2006Option,
double Latitude,
double Longitude,
String^ ZipCode,
double Ss,
double S1,
double Tl,
int SiteClass,
double Fa,
double Fv
)
abstract SetIBC2006 :
Name : string *
DirFlag : int *
Eccen : float *
PeriodFlag : int *
CtType : int *
UserT : float *
UserZ : bool *
TopZ : float *
BottomZ : float *
R : float *
Omega : float *
Cd : float *
I : float *
IBC2006Option : int *
Latitude : float *
Longitude : float *
ZipCode : string *
Ss : float *
S1 : float *
Tl : float *
SiteClass : int *
Fa : float *
Fv : float -> int
Parameters
- Name
- Type: SystemString
- DirFlag
- Type: SystemInt32
- Eccen
- Type: SystemDouble
- PeriodFlag
- Type: SystemInt32
- CtType
- Type: SystemInt32
- UserT
- Type: SystemDouble
- UserZ
- Type: SystemBoolean
- TopZ
- Type: SystemDouble
- BottomZ
- Type: SystemDouble
- R
- Type: SystemDouble
- Omega
- Type: SystemDouble
- Cd
- Type: SystemDouble
- I
- Type: SystemDouble
- IBC2006Option
- Type: SystemInt32
- Latitude
- Type: SystemDouble
- Longitude
- Type: SystemDouble
- ZipCode
- Type: SystemString
- Ss
- Type: SystemDouble
- S1
- Type: SystemDouble
- Tl
- Type: SystemDouble
- SiteClass
- Type: SystemInt32
- Fa
- Type: SystemDouble
- Fv
- Type: SystemDouble
Return Value
Type:
Int32
See Also