cAreaObjGetLabelNameList Method

Retrieves the names and labels of all defined area objects.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetLabelNameList(
	ref int NumberNames,
	ref string[] MyName,
	ref string[] MyLabel,
	ref string[] MyStory
)

Parameters

NumberNames
Type: SystemInt32
The number of area object names retrieved by the program.
MyName
Type: SystemString
This is a one-dimensional array of area object names. The MyName array is created as a dynamic, zero-based, array by the API user:

Dim MyName() as String

The array is dimensioned to (NumberNames – 1) inside the program, filled with the names, and returned to the API user.

MyLabel
Type: SystemString
This is a one-dimensional array of area object labels. The MyLabel array is created as a dynamic, zero-based, array by the API user:

Dim MyLabel() as String

The array is dimensioned to (NumberNames – 1) inside the program, filled with the labels, and returned to the API user.

MyStory
Type: SystemString
This is a one-dimensional array of the story levels of the area objects. The MyStory array is created as a dynamic, zero-based, array by the API user:

Dim MyStory() as String

The array is dimensioned to (NumberNames – 1) inside the program, filled with the story levels, and returned to the API user.

Return Value

Type: Int32
Returns zero if the data is successfully retrieved, otherwise it returns nonzero.
Remarks
Examples
VB
Public Sub Example()
   Dim SapModel As cSapModel
   Dim EtabsObject As cOAPI
   Dim ret As Integer = -1
   Dim NumberNames As Integer
   Dim MyName() As String
   Dim MyLabel() As String
   Dim MyStory() As String

'create ETABS object
   EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

'start ETABS application
  ret = EtabsObject.ApplicationStart()

'create SapModel object
   SapModel = EtabsObject.SapModel

'initialize model
   ret = SapModel.InitializeNewModel()

'create steel deck template model
   ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

'get area object data
   ret = SapModel.AreaObj.GetLabelNameList(NumberNames, MyName, MyLabel, MyStory)

'close ETABS
   EtabsObject.ApplicationExit(False)

'clean up variables
   SapModel = Nothing
   EtabsObject = Nothing

End Sub
See Also