cStorySetSplice Method

Sets the splice height of a defined story

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetSplice(
	string Name,
	bool SpliceAbove,
	double SpliceHeight
)

Parameters

Name
Type: SystemString
The name of a defined story
SpliceAbove
Type: SystemBoolean
This is True if the story has a splice height, and False otherwise
SpliceHeight
Type: SystemDouble
The story splice height

Return Value

Type: Int32
Returns zero if the value is successfully set, otherwise returns nonzero.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim IsMasterStory As Boolean
       Dim SimilarToStory As String

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'set story splice information
       ret = SapModel.Story.SetSplice("Story2", True, 2)

   'get story splice information
       ret = SapModel.Story.GetSplice("Story2", SpliceAbove, SpliceHeight)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also