cSelectGetSelected Method |
Retrieves a list of selected objects
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetSelected(
ref int NumberItems,
ref int[] ObjectType,
ref string[] ObjectName
)
Function GetSelected (
ByRef NumberItems As Integer,
ByRef ObjectType As Integer(),
ByRef ObjectName As String()
) As Integer
int GetSelected(
int% NumberItems,
array<int>^% ObjectType,
array<String^>^% ObjectName
)
abstract GetSelected :
NumberItems : int byref *
ObjectType : int[] byref *
ObjectName : string[] byref -> int
Parameters
- NumberItems
- Type: SystemInt32
The number of selected objects
- ObjectType
- Type: SystemInt32
This is an array that includes the object type of each selected object.
- Point object
- Frame object
- Cable object
- Tendon object
- Area object
- Solid object
- Link object
- ObjectName
- Type: SystemString
This is an array that includes the name of each selected object
Return Value
Type:
Int32
Returns zero if the selection list is successfully retrieved, otherwise it returns a nonzero value
Remarks
See Also