cCaseStaticNonlinearStagedGetStageData_2 Method

Retrieves stage data for the specified stage in the specified load case

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetStageData_2(
	string Name,
	ref int Stage,
	ref int NumberOperations,
	ref int[] Operation,
	ref string[] ObjectType,
	ref string[] ObjectName,
	ref double[] Age,
	ref string[] MyType,
	ref string[] MyName,
	ref double[] SF
)

Parameters

Name
Type: SystemString
The name of an existing static nonlinear staged load case
Stage
Type: SystemInt32
The stage in the specified load case for which data is requested. Stages are numbered sequentially starting from 1
NumberOperations
Type: SystemInt32
The number of operations in the specified stage
Operation
Type: SystemInt32
This is an array that includes 1, 2, 3, 4, 5, 6, 7, or 11, indicating an operation type.
1Add structure
2Remove structure
3Load objects if new
4Load objects
5Change section properties
6Change section property modifiers
7Change releases
11Change section properties and age
ObjectType
Type: SystemString
This is an array that includes the object type associated with the specified operation. The object type may be one of the following:
  • Group
  • Frame
  • Cable
  • Tendon
  • Area
  • Solid
  • Link
  • Point

The following list shows which object types are applicable to each operation type:

Operation = 1 (Add structure)All object types
Operation = 2 (Remove structure)All object types
Operation = 3 (Load objects if new)All object types
Operation = 4 (Load objects)All object types
Operation = 5 (Change section properties)All object types except Point
Operation = 6 (Change section property modifiers)Group, Frame, Cable, Area
Operation = 7 (Change releases)Group, Frame
Operation = 11 (Change section properties and age)All object types except Point

ObjectName
Type: SystemString
This is an array that includes the name of the object associated with the specified operation. This is the name of a Group, Frame object, Cable object, Tendon object, Area object, Solid object, Link object or Point object, depending on the ObjectType item
Age
Type: SystemDouble
This is an array that includes the age of the added structure, at the time it is added, in days. This item applies only to operations with Operation = 1.
MyType
Type: SystemString
This is an array that includes a load type or an object type, depending on what is specified for the Operation item. This item applies only to operations with Operation = 3, 4, 5, 6, 7, or 11.

When Operation = 3 or 4, this is an array that includes Load or Accel, indicating the load type of an added load.

When Operation = 5 or 11, and the ObjectType item is Group, this is an array that includes Frame, Cable, Tendon, Area, Solid or Link, indicating the object type for which the section property is changed.

When Operation = 6 and the ObjectType item is Group, this is an array that includes Frame, Cable or Area, indicating the object type for which the section property modifiers are changed.

When Operation = 7 and the ObjectType item is Group, this is an array that includes Frame, indicating the object type for which the releases are changed.

When Operation = 5, 6, 7, or 11, and the ObjectType item is not Group and not Point, this item is ignored and the type is picked up from the ObjectType item.

MyName
Type: SystemString
This is an array that includes a load assignment or an object name, depending on what is specified for the Operation item. This item applies only to operations with Operation = 3, 4, 5, 6, 7, or 11.

When Operation = 3 or 4, this is an array that includes the name of the load assigned to the operation. If the associated MyType (load type) item is Load, this item is the name of a defined load pattern. If the associated MyType (load type) item is Accel, this item is UX, UY, UZ, RX, RY or RZ, indicating the direction of the load.

When Operation = 5 or 11, this is the name of a Frame, Cable, Tendon, Area, Solid or Link object, depending on the object type specified.

When Operation = 6, this is the name of a Frame, Cable or Area object, depending on the object type specified.

When Operation = 7, this is the name of a Frame object.

SF
Type: SystemDouble
This is an array that includes the scale factor for the load assigned to the operation, if any. [L/s2] for Accel UX UY and UZ; otherwise unitless

This item applies only to operations with Operation = 3 or 4.

Return Value

Type: Int32
Returns zero if the data is successfully retrieved; otherwise, it returns a nonzero value
Remarks