cDCoACI318_08_IBC2009SetPreference Method

Sets the value of a concrete design preference item.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetPreference(
	int Item,
	double Value
)

Parameters

Item
Type: SystemInt32
This is an integer between 1 and 13, inclusive, indicating the preference item considered.
  1. Number of interaction curves
  2. Number of interaction points
  3. Consider minimum eccentricity
  4. Seismic design category
  5. Phi tension controlled
  6. Phi compression controlled tied
  7. Phi compression controlled spiral
  8. Phi shear and/or torsion
  9. Phi shear seismic
  10. Phi joint shear
  11. Pattern live load factor
  12. Utilization factor limit
  13. Multi-response case design
Value
Type: SystemDouble
The value of the considered preference item.
  1. Number of interaction curves

    Value >= 4 and devisable by 4

  2. Number of interaction points

    Value >= 5 and odd

  3. Consider minimum eccentricity

    0 = No

    Any other value = Yes

  4. Seismic design category
    1. A
    2. B
    3. C
    4. D
    5. E
    6. F
  5. Phi tension controlled

    Value > 0

  6. Phi compression controlled tied

    Value > 0

  7. Phi compression controlled spiral

    Value > 0

  8. Phi shear and/or torsion

    Value > 0

  9. Phi shear seismic

    Value > 0

  10. Phi joint shear

    Value > 0

  11. Pattern live load factor

    Value >= 0

  12. Utilization factor limit

    Value > 0

  13. Multi-response case design
    1. Envelopes
    2. Step-by step
    3. Last step
    4. Envelopes - All
    5. Step-by step - All

Return Value

Type: Int32
Returns zero if the item is successfully set; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
   Dim SapModel As cSapModel
   Dim EtabsObject As cOAPI
   Dim ret As Integer = -1

'create ETABS object
   EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

'start ETABS application
  ret = EtabsObject.ApplicationStart()

'create SapModel object
   SapModel = EtabsObject.SapModel

'initialize model
   ret = SapModel.InitializeNewModel()

'create steel deck template model
   ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

'create new concrete frame section property
   ret = SapModel.PropFrame.SetRectangle("R1", "4000Psi", 20, 12)

'set frame section property
   ret = SapModel.FrameObj.SetSection("8", "R1")

'set concrete design code
   ret = SapModel.DesignConcrete.SetCode("ACI 318-08/IBC 2009")

'run analysis
   System.IO.Directory.CreateDirectory("c:\CSI_API_temp")
   ret = SapModel.File.Save("C:\CSI_API_temp\example.edb")
   ret = SapModel.Analyze.RunAnalysis

'start concrete design
   ret = SapModel.DesignConcrete.StartDesign()

'set preference item
   ret = SapModel.DesignConcrete.ACI318_08_IBC2009.SetPreference(2, 9)

'close ETABS
   EtabsObject.ApplicationExit(False)

'clean up variables
   SapModel = Nothing
   EtabsObject = Nothing

End Sub
See Also