cPropLinkSetLinear Method |
Initializes a linear-type link property. If this function is called for an existing link property,
all items for the property are reset to their default value.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetLinear(
string Name,
ref bool[] DOF,
ref bool[] Fixed,
ref double[] Ke,
ref double[] Ce,
double DJ2,
double DJ3,
bool KeCoupled = false,
bool CeCoupled = false,
string Notes = "",
string GUID = ""
)
Function SetLinear (
Name As String,
ByRef DOF As Boolean(),
ByRef Fixed As Boolean(),
ByRef Ke As Double(),
ByRef Ce As Double(),
DJ2 As Double,
DJ3 As Double,
Optional KeCoupled As Boolean = false,
Optional CeCoupled As Boolean = false,
Optional Notes As String = "",
Optional GUID As String = ""
) As Integer
int SetLinear(
String^ Name,
array<bool>^% DOF,
array<bool>^% Fixed,
array<double>^% Ke,
array<double>^% Ce,
double DJ2,
double DJ3,
bool KeCoupled = false,
bool CeCoupled = false,
String^ Notes = L"",
String^ GUID = L""
)
abstract SetLinear :
Name : string *
DOF : bool[] byref *
Fixed : bool[] byref *
Ke : float[] byref *
Ce : float[] byref *
DJ2 : float *
DJ3 : float *
?KeCoupled : bool *
?CeCoupled : bool *
?Notes : string *
?GUID : string
(* Defaults:
let _KeCoupled = defaultArg KeCoupled false
let _CeCoupled = defaultArg CeCoupled false
let _Notes = defaultArg Notes ""
let _GUID = defaultArg GUID ""
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing or new link property.
If this is an existing property, that property is modified;
otherwise, a new property is added. - DOF
- Type: SystemBoolean
- Fixed
- Type: SystemBoolean
This is a boolean array, dimensioned to 5,
indicating if the specified degree of freedom is fixed (restrained).
Value | Fixity |
---|
Fixed(0) | U1 fixity if DOF(0) = True |
Fixed(1) | U2 fixity if DOF(1) = True |
Fixed(2) | U3 fixity if DOF(2) = True |
Fixed(3) | R1 fixity if DOF(3) = True |
Fixed(4) | R2 fixity if DOF(4) = True |
Fixed(5) | R3 fixity if DOF(5) = True |
The term Fixed(n) applies only when
DOF(n) = True
- Ke
- Type: SystemDouble
- Ce
- Type: SystemDouble
- DJ2
- Type: SystemDouble
- DJ3
- Type: SystemDouble
- KeCoupled (Optional)
- Type: SystemBoolean
This item is True if the link stiffness, Ke, is coupled.
There are 21 terms in the Ke array if Ke is coupled;
otherwise there are 6 terms - CeCoupled (Optional)
- Type: SystemBoolean
This item is True if the link damping, Ce, is coupled.
There are 21 terms in the Ce array if Ce is coupled;
otherwise there are 6 terms - Notes (Optional)
- Type: SystemString
- GUID (Optional)
- Type: SystemString
The GUID (global unique identifier), if any, assigned to the property.
If this item is input as Default, the program assigns a GUID to the property.
Return Value
Type:
Int32returns zero if the property is successfully initialized;
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim DOF() As Boolean
Dim Fixed() As Boolean
Dim Ke() As Double
Dim Ce() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ReDim DOF(5)
ReDim Fixed(5)
ReDim Ke(5)
ReDim Ce(5)
DOF(0) = True
Ke(0) = 12
ret = SapModel.PropLink.SetLinear("L1", DOF, Fixed, Ke, Ce, 0, 0)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also