cCaseDirectHistoryLinearGetLoads Method |
Retrieves the load data for the specified load case
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetLoads(
string Name,
ref int NumberLoads,
ref string[] LoadType,
ref string[] LoadName,
ref string[] Func,
ref double[] SF,
ref double[] Tf,
ref double[] At,
ref string[] CSys,
ref double[] Ang
)
Function GetLoads (
Name As String,
ByRef NumberLoads As Integer,
ByRef LoadType As String(),
ByRef LoadName As String(),
ByRef Func As String(),
ByRef SF As Double(),
ByRef Tf As Double(),
ByRef At As Double(),
ByRef CSys As String(),
ByRef Ang As Double()
) As Integer
int GetLoads(
String^ Name,
int% NumberLoads,
array<String^>^% LoadType,
array<String^>^% LoadName,
array<String^>^% Func,
array<double>^% SF,
array<double>^% Tf,
array<double>^% At,
array<String^>^% CSys,
array<double>^% Ang
)
abstract GetLoads :
Name : string *
NumberLoads : int byref *
LoadType : string[] byref *
LoadName : string[] byref *
Func : string[] byref *
SF : float[] byref *
Tf : float[] byref *
At : float[] byref *
CSys : string[] byref *
Ang : float[] byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing linear direct integration time history load case
- NumberLoads
- Type: SystemInt32
The number of loads assigned to the specified analysis case
- LoadType
- Type: SystemString
This is an array that includes Load or Accel, indicating the type of each load assigned to the load case
- LoadName
- Type: SystemString
This is an array that includes the name of each load assigned to the load case.
If the LoadType item is Load, this item is the name of a defined load pattern.
If the LoadType item is Accel, this item is U1, U2, U3, R1, R2 or R3, indicating the direction of the load.
- Func
- Type: SystemString
This is an array that includes the name of the time history function associated with each load
- SF
- Type: SystemDouble
This is an array that includes the scale factor of each load assigned to the load case.
[L/s2] for U1 U2 and U3; otherwise unitless
- Tf
- Type: SystemDouble
This is an array that includes the time scale factor of each load assigned to the load case
- At
- Type: SystemDouble
This is an array that includes the arrival time of each load assigned to the load case
- CSys
- Type: SystemString
This is an array that includes the name of the coordinate system associated with each load.
If this item is a blank string, the Global coordinate system is assumed.
This item applies only when the LoadType item is Accel.
- Ang
- Type: SystemDouble
This is an array that includes the angle between
the acceleration local 1 axis and the +X-axis of the coordinate system specified by the CSys item.
The rotation is about the Z-axis of the specified coordinate system. [deg]
Return Value
Type:
Int32
Returns zero if the data is successfully retrieved; otherwise it returns a nonzero value
Remarks
See Also