cAreaObjGetRebarDataSpandrel Method |
Retrieves rebar data for an area spandrel object
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetRebarDataSpandrel(
string Name,
ref int NumberRebarLayers,
ref string[] LayerID,
ref eWallSpandrelRebarLayerType[] LayerType,
ref double[] ClearCover,
ref int[] BarSizeIndex,
ref double[] BarArea,
ref double[] BarSpacing,
ref int[] NumberBars,
ref bool[] Confined
)
Function GetRebarDataSpandrel (
Name As String,
ByRef NumberRebarLayers As Integer,
ByRef LayerID As String(),
ByRef LayerType As eWallSpandrelRebarLayerType(),
ByRef ClearCover As Double(),
ByRef BarSizeIndex As Integer(),
ByRef BarArea As Double(),
ByRef BarSpacing As Double(),
ByRef NumberBars As Integer(),
ByRef Confined As Boolean()
) As Integer
int GetRebarDataSpandrel(
String^ Name,
int% NumberRebarLayers,
array<String^>^% LayerID,
array<eWallSpandrelRebarLayerType>^% LayerType,
array<double>^% ClearCover,
array<int>^% BarSizeIndex,
array<double>^% BarArea,
array<double>^% BarSpacing,
array<int>^% NumberBars,
array<bool>^% Confined
)
abstract GetRebarDataSpandrel :
Name : string *
NumberRebarLayers : int byref *
LayerID : string[] byref *
LayerType : eWallSpandrelRebarLayerType[] byref *
ClearCover : float[] byref *
BarSizeIndex : int[] byref *
BarArea : float[] byref *
BarSpacing : float[] byref *
NumberBars : int[] byref *
Confined : bool[] byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing area object
- NumberRebarLayers
- Type: SystemInt32
- LayerID
- Type: SystemString
- LayerType
- Type: ETABS2016eWallSpandrelRebarLayerType
- ClearCover
- Type: SystemDouble
- BarSizeIndex
- Type: SystemInt32
- BarArea
- Type: SystemDouble
- BarSpacing
- Type: SystemDouble
- NumberBars
- Type: SystemInt32
- Confined
- Type: SystemBoolean
Return Value
Type:
Int32
Remarks
See Also