cLinkObjDelete Method

Deletes link objects.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int Delete(
	string Name,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: SystemString
The name of an existing link object or group, depending on the value of the ItemType item.
ItemType (Optional)
Type: ETABS2016eItemType
This is one of the items in the eItemType enumeration.

If this item is Objects, the link object specified by the Name item is deleted.

If this item is Group, the all link objects in the group specified by the Name item are deleted.

If this item is SelectedObjects, all selected link objects are deleted, and the Name item is ignored.

Return Value

Type: Int32
Returns zero if the link objects are successfully deleted; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim Name1 As String
       Dim Name2 As String

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'add link object by points
       ret = SapModel.LinkObj.AddByPoint("2", "4", Name1)
       ret = SapModel.LinkObj.AddByPoint("1", "5", Name2)

   'delete link object
     ret = SapModel.LinkObj.Delete(Name1)

   'refresh view
       ret = SapModel.View.RefreshView

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also