Initializes a gap-type link property. If this function is called for an existing link property,
all items for the property are reset to their default value.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetGap(
string Name,
ref bool[] DOF,
ref bool[] Fixed,
ref bool[] Nonlinear,
ref double[] Ke,
ref double[] Ce,
ref double[] K,
ref double[] Dis,
double DJ2,
double DJ3,
string Notes = "",
string GUID = ""
)
Function SetGap (
Name As String,
ByRef DOF As Boolean(),
ByRef Fixed As Boolean(),
ByRef Nonlinear As Boolean(),
ByRef Ke As Double(),
ByRef Ce As Double(),
ByRef K As Double(),
ByRef Dis As Double(),
DJ2 As Double,
DJ3 As Double,
Optional Notes As String = "",
Optional GUID As String = ""
) As Integer
int SetGap(
String^ Name,
array<bool>^% DOF,
array<bool>^% Fixed,
array<bool>^% Nonlinear,
array<double>^% Ke,
array<double>^% Ce,
array<double>^% K,
array<double>^% Dis,
double DJ2,
double DJ3,
String^ Notes = L"",
String^ GUID = L""
)
abstract SetGap :
Name : string *
DOF : bool[] byref *
Fixed : bool[] byref *
Nonlinear : bool[] byref *
Ke : float[] byref *
Ce : float[] byref *
K : float[] byref *
Dis : float[] byref *
DJ2 : float *
DJ3 : float *
?Notes : string *
?GUID : string
(* Defaults:
let _Notes = defaultArg Notes ""
let _GUID = defaultArg GUID ""
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing or new link property.
If this is an existing property, that property is modified; otherwise, a new property is added - DOF
- Type: SystemBoolean
- Fixed
- Type: SystemBoolean
This is a boolean array, dimensioned to 5,
indicating if the specified degree of freedom is fixed (restrained).
Value | Fixity |
---|
Fixed(0) | U1 fixity if DOF(0) = True |
Fixed(1) | U2 fixity if DOF(1) = True |
Fixed(2) | U3 fixity if DOF(2) = True |
Fixed(3) | R1 fixity if DOF(3) = True |
Fixed(4) | R2 fixity if DOF(4) = True |
Fixed(5) | R3 fixity if DOF(5) = True |
- Nonlinear
- Type: SystemBoolean
This is a boolean array, dimensioned to 5,
indicating if nonlinear properties exist for a specified degree of freedom.
Value | Nonlinear |
---|
Nonlinear(0) | U1 has nonlinear properties |
Nonlinear(1) | U2 has nonlinear properties |
Nonlinear(2) | U3 has nonlinear properties |
Nonlinear(3) | R1 has nonlinear properties |
Nonlinear(4) | R2 has nonlinear properties |
Nonlinear(5) | R3 has nonlinear properties |
The term Nonlinear(n) applies only when
DOF(n) = True and Fixed(n) = False.
- Ke
- Type: SystemDouble
- Ce
- Type: SystemDouble
- K
- Type: SystemDouble
- Dis
- Type: SystemDouble
- DJ2
- Type: SystemDouble
- DJ3
- Type: SystemDouble
- Notes (Optional)
- Type: SystemString
- GUID (Optional)
- Type: SystemString
The GUID (global unique identifier), if any, assigned to the property.
If this item is input as Default, the program assigns a GUID to the property.
Return Value
Type:
Int32Returns zero if the property is successfully initialized;
otherwise it returns a nonzero value
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim MyDOF() As Boolean
Dim MyFixed() As Boolean
Dim MyNonLinear() as Boolean
Dim MyKe() As Double
Dim MyCe() As Double
Dim MyK() As Double
Dim MyDis() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ReDim MyDOF(5)
ReDim MyFixed(5)
ReDim MyNonLinear(5)
ReDim MyKe(5)
ReDim MyCe(5)
ReDim MyK(5)
ReDim MyDis(5)
MyDOF(0) = True
MyKe(0) = 12
MyCe(0) = 0.01
MyDOF(1) = True
MyNonLinear(1) = True
MyKe(1) = 12
MyCe(1) = 0.01
MyK(1) = 20
MyDis(1) = 1.2
MyDOF(2) = True
MyFixed(2) = True
ret = SapModel.PropLink.SetGap("G1", MyDOF, MyFixed, MyNonLinear, MyKe, MyCe, MyK, MyDis, 2, 0)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also