cCaseStaticNonlinearStagedSetSolControlParameters Method

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetSolControlParameters(
	string Name,
	int MaxTotalSteps,
	int MaxFailedSubSteps,
	int MaxIterCS,
	int MaxIterNR,
	double TolConvD,
	bool UseEventStepping,
	double TolEventD,
	int MaxLineSearchPerIter,
	double TolLineSearch,
	double LineSearchStepFact
)

Parameters

Name
Type: SystemString
MaxTotalSteps
Type: SystemInt32
MaxFailedSubSteps
Type: SystemInt32
MaxIterCS
Type: SystemInt32
MaxIterNR
Type: SystemInt32
TolConvD
Type: SystemDouble
UseEventStepping
Type: SystemBoolean
TolEventD
Type: SystemDouble
MaxLineSearchPerIter
Type: SystemInt32
TolLineSearch
Type: SystemDouble
LineSearchStepFact
Type: SystemDouble

Return Value

Type: Int32
See Also