cCaseStaticLinearGetLoads Method

Retrieves the load data for the specified load case

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetLoads(
	string Name,
	ref int NumberLoads,
	ref string[] LoadType,
	ref string[] LoadName,
	ref double[] SF
)

Parameters

Name
Type: SystemString
The name of an existing static linear load case.
NumberLoads
Type: SystemInt32
The number of loads assigned to the specified analysis case.
LoadType
Type: SystemString
This is an array that includes either Load or Accel, indicating the type of each load assigned to the load case.
LoadName
Type: SystemString
This is an array that includes the name of each load assigned to the load case.

If the LoadType item is Load, this item is the name of a defined load pattern.

If the LoadType item is Accel, this item is UX, UY, UZ, RX, RY or RZ, indicating the direction of the load.

SF
Type: SystemDouble

Return Value

Type: Int32
Returns zero if the data is successfully retrieved; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
   Dim SapModel As cSapModel
   Dim EtabsObject As cOAPI
   Dim ret As Integer = -1
   Dim MyLoadType() As String
   Dim MyLoadName() As String
   Dim MySF() As Double
   Dim NumberLoads As Long
   Dim LoadType() As String
   Dim LoadName() As String
   Dim SF() As Double

'create ETABS object
   EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

'start ETABS application
  ret = EtabsObject.ApplicationStart()

'create SapModel object
   SapModel = EtabsObject.SapModel

'initialize model
   ret = SapModel.InitializeNewModel()

'create steel deck template model
    ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

'add static linear load case
    ret = SapModel.LoadCases.StaticLinear.SetCase("LCASE1")

'set load data
    ReDim MyLoadType(1)
    ReDim MyLoadName(1)
    ReDim MySF(1)
    MyLoadType(0) = "Load"
    MyLoadName(0) = "DEAD"
    MySF(0) = 0.7
    MyLoadType(1) = "Accel"
    MyLoadName(1) = "UZ"
    MySF(1) = 1.2
    ret = SapModel.LoadCases.StaticLinear.SetLoads("LCASE1", 2, MyLoadType, MyLoadName, MySF)

'get load data
    ret = SapModel.LoadCases.StaticLinear.GetLoads("LCASE1", NumberLoads, LoadType, LoadName, SF)

'refresh view
   ret = SapModel.View.RefreshView(0, False)

'close ETABS
   EtabsObject.ApplicationExit(False)

'clean up variables
   SapModel = Nothing
   EtabsObject = Nothing

End Sub
See Also